summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-28 05:52:57 +0100
committerSam James <sam@gentoo.org>2021-09-28 05:53:20 +0100
commit0c810a8e6ed6cfcd092b4fd819b574a7dc3b5642 (patch)
treebaed33e415794333ed94015e50448d961c58827c /net-dns
parentnet-ftp/ftp: version bump, EAPI bump, fix segv (diff)
downloadgentoo-0c810a8e6ed6cfcd092b4fd819b574a7dc3b5642.tar.gz
gentoo-0c810a8e6ed6cfcd092b4fd819b574a7dc3b5642.tar.bz2
gentoo-0c810a8e6ed6cfcd092b4fd819b574a7dc3b5642.zip
net-dns/dnscrypt-proxy: add 2.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild105
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild4
3 files changed, 108 insertions, 2 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index e799b8395ee6..28b447df6e50 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1,3 @@
DIST dnscrypt-proxy-2.0.45.tar.gz 2721610 BLAKE2B cddeafec2a2fa8179b722a1b4fe8527bcb3991f5d9e04e31667ea8c38deda5b8c9a3c3a3c16e4e2f5d1bfdb5f8d540c6d61273c34df27f4a78215736b240846f SHA512 becfe3c2d4567725e6b7e973647163e32dd2eaae361087bb05c90b6ddc3b0db0891c2725f6b5c255b8965990832bad53bd6ef137be54a342f46594f3633fe47a
DIST dnscrypt-proxy-2.1.0.tar.gz 6248378 BLAKE2B 6b0db8eae8bd380634a86ee2026fb6a3f64d0874a77633f9b8ef46bd37601ebf8d9163516b5ccc371d5354023d5c5c542384718aa885dd1f99809a7b98df5de2 SHA512 201a2741f4703872901fa9c045323444d2939d662316e0026f7aa33c7136e45a564225106884ed80522be5247e128c70ced176c83333ddaacc66dc0f87c74029
+DIST dnscrypt-proxy-2.1.1.tar.gz 6114345 BLAKE2B 9d68d94d1fc142d53ed74840080feca56d7abf606b8df9b2ebea7a69b75f13cdc93be53418e6101d30d31d6f4130b3794c1029a5972e129a4c06feeff7dd81e7 SHA512 1118d79aad8d3e3629616c203194a5346f00fcfe88783ebddc6f167d22a82006f26022e728c57905aa82997b87b77f0841f7c1b60e0f8e5335f9df142b759c21
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild
new file mode 100644
index 000000000000..3e4c51ce549e
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.1.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/DNSCrypt/${PN}"
+
+inherit fcaps go-module systemd
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
+
+LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+pie"
+
+BDEPEND=">=dev-lang/go-1.13"
+RDEPEND="
+ acct-group/dnscrypt-proxy
+ acct-user/dnscrypt-proxy
+"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0-config-full-paths.patch"
+)
+
+src_compile() {
+ pushd "${PN}" >/dev/null || die
+ go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
+ popd >/dev/null || die
+}
+
+src_test() {
+ cd "${PN}" || die
+ go test -mod=vendor -buildmode="$(usex pie pie default)" || die "Failed to run tests"
+}
+
+src_install() {
+ pushd "${PN}" >/dev/null || die
+
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins example-{allowed,blocked}-{ips.txt,names.txt}
+ doins example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ popd >/dev/null || die
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blocklist/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/DNSCrypt/${PN}/wiki"
+}
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
index ef2293465894..3e4c51ce549e 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
SLOT="0"
-IUSE="pie"
+IUSE="+pie"
BDEPEND=">=dev-lang/go-1.13"
RDEPEND="
@@ -31,7 +31,7 @@ RDEPEND="
FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
PATCHES=(
- "${FILESDIR}/${PN}-2.0.45-config-full-paths.patch"
+ "${FILESDIR}/${PN}-2.1.0-config-full-paths.patch"
)
src_compile() {