summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/validns
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/validns')
-rw-r--r--net-dns/validns/Manifest2
-rw-r--r--net-dns/validns/metadata.xml16
-rw-r--r--net-dns/validns/validns-0.7.ebuild26
-rw-r--r--net-dns/validns/validns-0.8.ebuild26
4 files changed, 70 insertions, 0 deletions
diff --git a/net-dns/validns/Manifest b/net-dns/validns/Manifest
new file mode 100644
index 000000000000..7c9de298e57e
--- /dev/null
+++ b/net-dns/validns/Manifest
@@ -0,0 +1,2 @@
+DIST validns-0.7.tar.gz 185377 SHA256 372f37f2ae2ff44251ffc0ceed7ad60bdb3e6a3a692e69d186566b9d19407591 SHA512 2309aabdf863ff51b035ecf4536f2499d9373aed057a07546bdf4498c06c8e6cb36fc8094a8e3b26b49bd12c245ea705421744b354e46c3cc3927f6c3b33e72a WHIRLPOOL d405c33b640a9f21608021bbc1e634393b8a36097f5a0b20c87b330ab3948facfcaab25f9f2596b9401759b534618a53b1dcdd384790f9f5144e2778ae3a185f
+DIST validns-0.8.tar.gz 190325 SHA256 df2db0eaa998a0411ff4c1c4e417eb82d32aec4835f92f45f26c66c8d1d5bd22 SHA512 2443bb8a7373f27d41ab3be1a92b61696d05b74afa42c19db54f6e999e4a634499faa44a5feefd3bc515bc677a8ef0a076092cf13316eff6d1cc504ff9702038 WHIRLPOOL e9a743409457452461a22dd5f57efee7df1e96a9f20665490d7066c87a4609e0a13e6a8a2866f18cc017eee82120b22ddce3794ad381702cda7a82de9935339e
diff --git a/net-dns/validns/metadata.xml b/net-dns/validns/metadata.xml
new file mode 100644
index 000000000000..cce03d071dbf
--- /dev/null
+++ b/net-dns/validns/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tom@whyscream.net</email>
+ <name>Tom Hendrikx</name>
+ <description>Please assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>proxy-maintainer, please CC on bugs</description>
+ </maintainer>
+ <longdescription>Validns is a standalone command line RFC 1034/1035 zone file validation tool that, in addition to basic syntactic and semantic zone checks, includes DNSSEC signature verification and NSEC/NSEC3 chain validation, as well a number of optional policy checks on the zone.</longdescription>
+</pkgmetadata>
diff --git a/net-dns/validns/validns-0.7.ebuild b/net-dns/validns/validns-0.7.ebuild
new file mode 100644
index 000000000000..481f0ac27ad3
--- /dev/null
+++ b/net-dns/validns/validns-0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A high performance DNS/DNSSEC zone validator"
+HOMEPAGE="http://www.validns.net/"
+SRC_URI="http://www.validns.net/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/judy"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-perl/Test-Command-Simple )
+"
+
+src_install() {
+ dobin validns
+ doman validns.1
+ dodoc {notes,technical-notes,todo,usage}.mdwn Changes README
+}
diff --git a/net-dns/validns/validns-0.8.ebuild b/net-dns/validns/validns-0.8.ebuild
new file mode 100644
index 000000000000..481f0ac27ad3
--- /dev/null
+++ b/net-dns/validns/validns-0.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A high performance DNS/DNSSEC zone validator"
+HOMEPAGE="http://www.validns.net/"
+SRC_URI="http://www.validns.net/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/judy"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-perl/Test-Command-Simple )
+"
+
+src_install() {
+ dobin validns
+ doman validns.1
+ dodoc {notes,technical-notes,todo,usage}.mdwn Changes README
+}