summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2023-06-05 12:45:32 +0200
committerSven Wegener <swegener@gentoo.org>2023-06-05 13:03:22 +0200
commitbcacc1b10859dd4bcee4c494378eba8b2dc1b173 (patch)
treea671beda037a77012528037f173752b60606622f /net-dns/pdns
parentcargo.eclass: fix typos and doc readability (diff)
downloadgentoo-bcacc1b10859dd4bcee4c494378eba8b2dc1b173.tar.gz
gentoo-bcacc1b10859dd4bcee4c494378eba8b2dc1b173.tar.bz2
gentoo-bcacc1b10859dd4bcee4c494378eba8b2dc1b173.zip
net-dns/pdns: remove lua USE flag, bug #907676
Besides the lua backend, pdns always requires lua for internal functions. Closes: https://bugs.gentoo.org/907676 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/pdns-4.7.4.ebuild4
-rw-r--r--net-dns/pdns/pdns-4.8.0.ebuild9
2 files changed, 6 insertions, 7 deletions
diff --git a/net-dns/pdns/pdns-4.7.4.ebuild b/net-dns/pdns/pdns-4.7.4.ebuild
index d5fc1d607c57..a488c22893d4 100644
--- a/net-dns/pdns/pdns-4.7.4.ebuild
+++ b/net-dns/pdns/pdns-4.7.4.ebuild
@@ -23,9 +23,9 @@ KEYWORDS="amd64 x86"
IUSE="debug doc geoip ldap lmdb lua-records mysql postgres remote sodium sqlite systemd tools tinydns test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="lua-records? ( ${LUA_REQUIRED_USE} )"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
-DEPEND="lua-records? ( ${LUA_DEPS} )
+DEPEND="${LUA_DEPS}
dev-libs/openssl:=
dev-libs/boost:=
lmdb? ( >=dev-db/lmdb-0.9.29 )
diff --git a/net-dns/pdns/pdns-4.8.0.ebuild b/net-dns/pdns/pdns-4.8.0.ebuild
index 5640b0019192..f4cd9f633ea0 100644
--- a/net-dns/pdns/pdns-4.8.0.ebuild
+++ b/net-dns/pdns/pdns-4.8.0.ebuild
@@ -16,12 +16,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc geoip ldap lmdb lua lua-records mysql odbc postgres remote sodium sqlite systemd tools tinydns test"
+IUSE="debug doc geoip ldap lmdb lua-records mysql odbc postgres remote sodium sqlite systemd tools tinydns test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} ) lua-records? ( lua )"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
-DEPEND="lua? ( ${LUA_DEPS} )
+DEPEND="${LUA_DEPS}
dev-libs/openssl:=
dev-libs/boost:=
lmdb? ( >=dev-db/lmdb-0.9.29 )
@@ -52,12 +52,11 @@ pkg_setup() {
}
src_configure() {
- local cnf_dynmodules="pipe bind" # the default backends, always enabled
+ local cnf_dynmodules="bind lua2 pipe" # the default backends, always enabled
use geoip && cnf_dynmodules+=" geoip"
use ldap && cnf_dynmodules+=" ldap"
use lmdb && cnf_dynmodules+=" lmdb"
- use lua && cnf_dynmodules+=" lua2"
use mysql && cnf_dynmodules+=" gmysql"
use odbc && cnf_dynmodules+=" godbc"
use postgres && cnf_dynmodules+=" gpgsql"