summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2016-07-19 21:08:11 +0000
committerSven Wegener <swegener@gentoo.org>2016-07-19 22:02:49 +0000
commitff3fb60e40daf53c31d241107e8ffb3497d11583 (patch)
treeb6d79a1917130b3babeb5867719e97bceecf73d2 /net-dns/pdns-recursor
parentnet-dns/pdns-recursor: Rename init script, bug #322581 (diff)
downloadgentoo-ff3fb60e40daf53c31d241107e8ffb3497d11583.tar.gz
gentoo-ff3fb60e40daf53c31d241107e8ffb3497d11583.tar.bz2
gentoo-ff3fb60e40daf53c31d241107e8ffb3497d11583.zip
net-dns/pdns-recursor: Switch src_install() to upstream automake
Package-Manager: portage-2.2.28 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor4
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.0.0.ebuild13
2 files changed, 11 insertions, 6 deletions
diff --git a/net-dns/pdns-recursor/files/pdns-recursor b/net-dns/pdns-recursor/files/pdns-recursor
index 151176b5ad0e..f114d5be4a2d 100644
--- a/net-dns/pdns-recursor/files/pdns-recursor
+++ b/net-dns/pdns-recursor/files/pdns-recursor
@@ -17,12 +17,12 @@ start() {
stop() {
ebegin "Stopping PowerDNS Recursor"
- /usr/sbin/rec_control quit &>/dev/null
+ /usr/bin/rec_control quit &>/dev/null
eend $?
}
ping() {
ebegin "Pinging PowerDNS Recursor"
- /usr/sbin/rec_control ping &>/dev/null
+ /usr/bin/rec_control ping &>/dev/null
eend $?
}
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.0.0.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.0.0.ebuild
index 4fd1a47d7d59..392772611d4b 100644
--- a/net-dns/pdns-recursor/pdns-recursor-4.0.0.ebuild
+++ b/net-dns/pdns-recursor/pdns-recursor-4.0.0.ebuild
@@ -44,11 +44,16 @@ src_configure() {
}
src_install() {
- dosbin pdns_recursor rec_control
- doman pdns_recursor.1 rec_control.1
+ default
- insinto /etc/powerdns
- doins "${FILESDIR}"/recursor.conf
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=/quiet=on/' \
+ -e 's/^# chroot=/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
doinitd "${FILESDIR}"/pdns-recursor