summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-07-12 19:25:55 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-13 08:42:14 +0100
commitbecf09a92f487bce6bc6087959c08fe6d04ee5dd (patch)
tree732f55fdb3a581f90f1cd6e45bac511d7bb93ac7 /net-dns/knot
parentsci-mathematics/why3-for-spark: Version bump to 2018 (diff)
downloadgentoo-becf09a92f487bce6bc6087959c08fe6d04ee5dd.tar.gz
gentoo-becf09a92f487bce6bc6087959c08fe6d04ee5dd.tar.bz2
gentoo-becf09a92f487bce6bc6087959c08fe6d04ee5dd.zip
net-dns/knot: bump to 2.6.8
Closes: https://github.com/gentoo/gentoo/pull/9204
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-2.6.8.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index d3d63dc1c223..4a84be762d9e 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,3 +1,4 @@
DIST knot-2.5.7.tar.xz 1084656 BLAKE2B c2d583625a19f6a61248b3b42cdf14f5bb2bdbafdb20be6b0813744095a4016a4be2eb5e2dfaff0628238c60153480175a86706db0b88569d76156f86ba33968 SHA512 96e375f556309bb89cea982dda169cef70c23d03c48282110e47a44849c1102cd37d98aa7650781b399f5d932b724b8a935f0b9e55e4920465ae7b74a0d1d55a
DIST knot-2.6.6.tar.xz 1120340 BLAKE2B 374d9b78f2ef2143d1221fced29184a52ee3773abd7cb08b6b48910f6ffc0f7c4f07c00d17d28344c93d71a709363bdf855d20587f87da622153c44d08d85fd8 SHA512 bd7a36decc74041f12971045cd69b8cc9e7ecce68f8d2b4cddc9b5f23ee96e8ed290d98fe9e6c441d6727ad4395bea615cbd9ec19cc641abce19ef8da6371972
DIST knot-2.6.7.tar.xz 1121120 BLAKE2B c3000a08a8d873efc5a120d0f0154bcd16be0162ce3c21d74041181183c5f6f1600eeab3546737591ccd1522c8119202dc1f7dd576b70d4c006c0619b904f54a SHA512 021810b396e9aaca140c6df858c8dcb9a4be6ac8d64a413195b88d8073d39e1de0604058343bff7534d39f32de27b0e0bc2271a0e545bb9f809adfe1bfaec9a9
+DIST knot-2.6.8.tar.xz 1121740 BLAKE2B 2da7e20630fec53952c6892ee4002afeee0c36ef5cb271346caf1760389abaacac7f11dd0b24950ff5eedca40564ccf70c25b5c8548564bdd61c78a1bd9cf93e SHA512 3300985bd4fbf88b58fbb5ba06bdd3dcbe7a50885baa89f9db47811c071a93994a2b17a0dbd27d185feade056ed5d65eef712eedb26de5a4101da363a7c24967
diff --git a/net-dns/knot/knot-2.6.8.ebuild b/net-dns/knot/knot-2.6.8.ebuild
new file mode 100644
index 000000000000..2c624d4be58a
--- /dev/null
+++ b/net-dns/knot/knot-2.6.8.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu
+ dev-python/lmdb
+ net-libs/gnutls
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn )
+ libidn2? ( net-dns/libidn2 )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}