summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 12:32:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 16:54:19 +0100
commitf8f597406d33f49f5db300bd7b16eabf7751f365 (patch)
tree9f4ad931b8ae4fde47bef1f1cd2dbe3bf803c1b5 /net-dns/hash-slinger
parentprofiles/base: Mask dev-python/rdflib[redland] (diff)
downloadgentoo-f8f597406d33f49f5db300bd7b16eabf7751f365.tar.gz
gentoo-f8f597406d33f49f5db300bd7b16eabf7751f365.tar.bz2
gentoo-f8f597406d33f49f5db300bd7b16eabf7751f365.zip
net-dns/hash-slinger: Switch to python-single-r1
Use python-single-r1 since the dep net-dns/unbound is single-r1. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns/hash-slinger')
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild18
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.7-r2.ebuild (renamed from net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild)18
2 files changed, 20 insertions, 16 deletions
diff --git a/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
index a2ff821691bc..a5e14629412a 100644
--- a/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
+++ b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-r1
+inherit python-single-r1
DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
@@ -21,12 +21,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
RDEPEND="
${PYTHON_DEPS}
- dev-python/dnspython[$PYTHON_USEDEP]
- dev-python/ipaddr[$PYTHON_USEDEP]
- dev-python/m2crypto[$PYTHON_USEDEP]
- net-dns/unbound[python,$PYTHON_USEDEP]
+ net-dns/unbound[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+ openpgp? ( dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}] )
+ ')
ipsec? ( net-vpn/libreswan[dnssec] )
- openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
ssh? ( net-misc/openssh )
"
@@ -38,7 +40,7 @@ src_install() {
use ipsec && tools+=" ipseckey"
for tool in $tools ; do
doman ${tool}.1
- python_foreach_impl python_doscript ${tool}
+ python_doscript ${tool}
done
dodoc BUGS CHANGES README
}
diff --git a/net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild b/net-dns/hash-slinger/hash-slinger-2.7-r2.ebuild
index 161c87a31f2d..e36c1758e267 100644
--- a/net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild
+++ b/net-dns/hash-slinger/hash-slinger-2.7-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-r1
+inherit python-single-r1
DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
@@ -21,12 +21,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
RDEPEND="
${PYTHON_DEPS}
- dev-python/dnspython[$PYTHON_USEDEP]
- dev-python/ipaddr[$PYTHON_USEDEP]
- dev-python/m2crypto[$PYTHON_USEDEP]
- net-dns/unbound[python,$PYTHON_USEDEP]
+ net-dns/unbound[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+ openpgp? ( dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}] )
+ ')
ipsec? ( net-vpn/libreswan[dnssec] )
- openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
ssh? ( net-misc/openssh )
"
@@ -38,7 +40,7 @@ src_install() {
use ipsec && tools+=" ipseckey"
for tool in $tools ; do
doman ${tool}.1
- python_foreach_impl python_doscript ${tool}
+ python_doscript ${tool}
done
dodoc BUGS CHANGES README
}