summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-12 00:00:57 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-12 00:07:18 +0200
commitb4dd6303339ca68635747819b7fb67fb34390c61 (patch)
tree8062614989e4861f15eeeb4ae268e0716043c2e2 /net-analyzer
parentsci-visualization/paraview: fix gcc 11 build (again) (diff)
downloadgentoo-b4dd6303339ca68635747819b7fb67fb34390c61.tar.gz
gentoo-b4dd6303339ca68635747819b7fb67fb34390c61.tar.bz2
gentoo-b4dd6303339ca68635747819b7fb67fb34390c61.zip
net-analyzer/suricata: leave sphinx-build and pdflatex alone
Upstream build scripts look for the two and if they are present, attempt to generate documentation. Automagic aside, this presently only works with Sphinx versions older than 4.0.0 - and in any case release tarballs include both PDF guides and man pages. Closes: https://bugs.gentoo.org/789528 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/suricata/files/suricata-5.0.6_configure-no-sphinx-pdflatex-automagic.patch26
-rw-r--r--net-analyzer/suricata/suricata-5.0.6.ebuild1
-rw-r--r--net-analyzer/suricata/suricata-6.0.2.ebuild1
3 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/suricata/files/suricata-5.0.6_configure-no-sphinx-pdflatex-automagic.patch b/net-analyzer/suricata/files/suricata-5.0.6_configure-no-sphinx-pdflatex-automagic.patch
new file mode 100644
index 000000000000..be5805e67f87
--- /dev/null
+++ b/net-analyzer/suricata/files/suricata-5.0.6_configure-no-sphinx-pdflatex-automagic.patch
@@ -0,0 +1,26 @@
+No configure options to disable looking for these, redundant for releases
+because the tarballs already contain both PDF documentation and man pages,
+and as of 2021-05-11 doc generation is not compatible with sphinx-4.0.0+
+due to conf.py calling long-deprecated app.add_stylesheet() rather
+than app.add_css_file().
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2423,7 +2423,7 @@
+ fi
+
+ # sphinx for documentation
+- AC_PATH_PROG(HAVE_SPHINXBUILD, sphinx-build, "no")
++ HAVE_SPHINXBUILD="no"
+ if test "$HAVE_SPHINXBUILD" = "no"; then
+ enable_sphinxbuild=no
+ if test -e "$srcdir/doc/userguide/suricata.1"; then
+@@ -2434,7 +2434,7 @@
+ AM_CONDITIONAL([HAVE_SURICATA_MAN], [test "x$have_suricata_man" = "xyes"])
+
+ # pdflatex for the pdf version of the user manual
+- AC_PATH_PROG(HAVE_PDFLATEX, pdflatex, "no")
++ HAVE_PDFLATEX="no"
+ if test "$HAVE_PDFLATEX" = "no"; then
+ enable_pdflatex=no
+ fi
diff --git a/net-analyzer/suricata/suricata-5.0.6.ebuild b/net-analyzer/suricata/suricata-5.0.6.ebuild
index 46d1458df40e..defd0c6f7f87 100644
--- a/net-analyzer/suricata/suricata-5.0.6.ebuild
+++ b/net-analyzer/suricata/suricata-5.0.6.ebuild
@@ -56,6 +56,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.0.1_configure-no-lz4-automagic.patch"
"${FILESDIR}/${PN}-5.0.1_default-config.patch"
+ "${FILESDIR}/${PN}-5.0.6_configure-no-sphinx-pdflatex-automagic.patch"
)
pkg_pretend() {
diff --git a/net-analyzer/suricata/suricata-6.0.2.ebuild b/net-analyzer/suricata/suricata-6.0.2.ebuild
index 7171dc94415d..061242b9a529 100644
--- a/net-analyzer/suricata/suricata-6.0.2.ebuild
+++ b/net-analyzer/suricata/suricata-6.0.2.ebuild
@@ -55,6 +55,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.0.1_configure-no-lz4-automagic.patch"
+ "${FILESDIR}/${PN}-5.0.6_configure-no-sphinx-pdflatex-automagic.patch"
"${FILESDIR}/${PN}-6.0.0_default-config.patch"
)