summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 08:06:55 +0000
committerSam James <sam@gentoo.org>2021-03-22 08:09:25 +0000
commit510474327c2ab9b61ddf6b6946caa40dabb2f52c (patch)
treebaee4383a61695e0bfa89a2c79a56c4e6bdee83e /net-analyzer
parentnet-analyzer/httping: port to EAPI 7 (diff)
downloadgentoo-510474327c2ab9b61ddf6b6946caa40dabb2f52c.tar.gz
gentoo-510474327c2ab9b61ddf6b6946caa40dabb2f52c.tar.bz2
gentoo-510474327c2ab9b61ddf6b6946caa40dabb2f52c.zip
net-analyzer/httping: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/httping-2.5.ebuild2
-rw-r--r--net-analyzer/httping/httping-9999999.ebuild21
2 files changed, 15 insertions, 8 deletions
diff --git a/net-analyzer/httping/httping-2.5.ebuild b/net-analyzer/httping/httping-2.5.ebuild
index 70c43b0cd87e..bef7c95c9fd1 100644
--- a/net-analyzer/httping/httping-2.5.ebuild
+++ b/net-analyzer/httping/httping-2.5.ebuild
@@ -52,6 +52,8 @@ src_configure() {
if use ncurses ; then
local ncurses_flags="$($(tc-getPKG_CONFIG) --libs ncurses)"
+ # Don't require ncurses with unicode support
+ # bug #731950
sed -i -e "s/-lncursesw/${ncurses_flags}/" Makefile || die
append-ldflags "${ncurses_flags}"
fi
diff --git a/net-analyzer/httping/httping-9999999.ebuild b/net-analyzer/httping/httping-9999999.ebuild
index 32a92c0aead0..b9faaaf1fedd 100644
--- a/net-analyzer/httping/httping-9999999.ebuild
+++ b/net-analyzer/httping/httping-9999999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+
+inherit git-r3 toolchain-funcs flag-o-matic
DESCRIPTION="like ping but for HTTP requests"
HOMEPAGE="https://www.vanheusden.com/httping/"
@@ -10,7 +11,6 @@ EGIT_REPO_URI="https://github.com/flok99/httping"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="debug fftw libressl l10n_nl ncurses ssl +tfo"
RDEPEND="
@@ -21,10 +21,8 @@ RDEPEND="
libressl? ( dev-libs/libressl:0= )
)
"
-DEPEND="
- ${RDEPEND}
- ncurses? ( virtual/pkgconfig )
-"
+DEPEND="${RDEPEND}"
+BDEPEND="ncurses? ( virtual/pkgconfig )"
# This would bring in test? ( dev-util/cppcheck ) but unlike
# upstream we should only care about compile/run time testing
@@ -49,7 +47,14 @@ src_configure() {
# not an autotools script
echo > makefile.inc || die
- use ncurses && LDFLAGS+=" $( $( tc-getPKG_CONFIG ) --libs ncurses )"
+ if use ncurses ; then
+ local ncurses_flags="$($(tc-getPKG_CONFIG) --libs ncurses)"
+
+ # Don't require ncurses with unicode support
+ # bug #731950
+ sed -i -e "s/-lncursesw/${ncurses_flags}/" Makefile || die
+ append-ldflags "${ncurses_flags}"
+ fi
}
src_compile() {