summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-20 14:58:42 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-20 14:59:00 +0100
commit4ef0978b8027944c43e35138a608f553c5f71946 (patch)
treeadb09bd5b01ae8d6e7fd9f2a9e9a1bfda9f0a7d9 /net-analyzer
parentapp-portage/grs: 0.6 stable on x86 (diff)
downloadgentoo-4ef0978b8027944c43e35138a608f553c5f71946.tar.gz
gentoo-4ef0978b8027944c43e35138a608f553c5f71946.tar.bz2
gentoo-4ef0978b8027944c43e35138a608f553c5f71946.zip
net-analyzer/sarg: Fix more compiler warnings (bug #645006).
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.11-format.patch36
-rw-r--r--net-analyzer/sarg/sarg-2.3.11.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/sarg/files/sarg-2.3.11-format.patch b/net-analyzer/sarg/files/sarg-2.3.11-format.patch
new file mode 100644
index 000000000000..f2dc7d39b1e8
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.11-format.patch
@@ -0,0 +1,36 @@
+--- a/report.c
++++ b/report.c
+@@ -54,7 +54,7 @@
+ char accsmart[MAXLEN];
+ char crc2[MAXLEN/2 -1];
+ char siteind[MAX_TRUNCATED_URL];
+- char arqtt[256];
++ char arqtt[MAX_USER_FNAME_LEN * 2 + MAXLEN + 10];
+ char *oldurltt=NULL;
+ char oldaccdiatt[11],oldacchoratt[9];
+ char tmp3[MAXLEN];
+--- a/index.c
++++ b/index.c
+@@ -89,9 +89,9 @@
+ char monthdir[MAXLEN];
+ char monthname1[9], monthname2[9];
+ char nmonth[30];
+- char monthnum[10];
++ char monthnum[15];
+ char dayindex[MAXLEN];
+- char daynum[10];
++ char daynum[15];
+ char title[80];
+ int yearsort[150];
+ int nyears;
+--- a/userinfo.c
++++ b/userinfo.c
+@@ -67,7 +67,7 @@
+ int skip;
+ int flen;
+ int count, clen;
+- char cstr[9];
++ char cstr[10];
+
+ last=NULL;
+ for (group=first_user_group ; group ; group=group->next) {
diff --git a/net-analyzer/sarg/sarg-2.3.11.ebuild b/net-analyzer/sarg/sarg-2.3.11.ebuild
index 33a65ab49a99..82677c354812 100644
--- a/net-analyzer/sarg/sarg-2.3.11.ebuild
+++ b/net-analyzer/sarg/sarg-2.3.11.ebuild
@@ -25,6 +25,7 @@ DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
PATCHES=(
"${FILESDIR}"/${PN}-2.3.10-config.patch
"${FILESDIR}"/${PN}-2.3.11-configure.patch
+ "${FILESDIR}"/${PN}-2.3.11-format.patch
)
src_prepare() {