summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-09 22:05:47 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-09 22:07:16 +0200
commit4e3df6975dd44939cf69b0c2cfc88d8f7db8ad5b (patch)
treee7baaad3f23e20f2f56029461ba5ea7148bb9e78 /net-analyzer
parentdev-python/cmd2: Use virtx to reenable selection buffer tests (diff)
downloadgentoo-4e3df6975dd44939cf69b0c2cfc88d8f7db8ad5b.tar.gz
gentoo-4e3df6975dd44939cf69b0c2cfc88d8f7db8ad5b.tar.bz2
gentoo-4e3df6975dd44939cf69b0c2cfc88d8f7db8ad5b.zip
net-analyzer/scapy: Version 2.4.3_rc3
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/scapy/Manifest1
-rw-r--r--net-analyzer/scapy/scapy-2.4.3_rc3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index ab629fbb523e..64a466f79c6e 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -3,3 +3,4 @@ DIST scapy-2.4.0.tar.gz 3182131 BLAKE2B af591b103c90736a5e62801f4c0ebd495e2e71c7
DIST scapy-2.4.2.tar.gz 3330071 BLAKE2B a40074594cd561b33d04364fba743fa5fe741b06b2ad8f8f9ebe9dfb0b9a3bc4f641cd16d99a4ba070fc0763d7cfeb8d3ecd056f162d509070cdd57d55d6ad9c SHA512 980f708a849ae26edca3eb6618a41668818c5883bca699f347f47a8964b3ee44a6ceefe4a12cb7d5fe6c13f5cbe2b7547938e53139f4ec9e6ef384e30c9bb6db
DIST scapy-2.4.3_rc1.tar.gz 2455703 BLAKE2B 7db2af39afad694b49296d0e02a7e649c31023fbb12d66faccb777e297240b84e39558dd0ba56dab159e8412cec93d868ec02542afa385e2ec49d1a80b8788d4 SHA512 29996996521d5802b435c27dee5ad91fdd3e974dc86a3ba1377c67eb5c81a639fdfa18790ca2275df54685a963f7c69bde10b01887ba54315ddef6d2c002f8d8
DIST scapy-2.4.3_rc2.tar.gz 2785755 BLAKE2B 75c89f22beafbc9350d0f42fd186a4860d0c3146d543c66a6a8561d9c644ce92496c678740abfdfaf5811e3da01de211c76b590920c0860fc04c61e8f19bf0eb SHA512 09e45742a87be31f9230f6948f4d746f16fcd37aaae257d456deefa4ed7d9adcd93f647910210d0fc7d8d1db05a6d62a3937550d560d6099672a3360dfd0c88d
+DIST scapy-2.4.3_rc3.tar.gz 2947417 BLAKE2B c01528cfdd96c39f5d4b103e4537b5f2b59019a9aaa86a6a264565f709e60adaa934bad1036b62a236127e81c82dda30c7f14aac23394eb90bdaed7377c9aaf5 SHA512 135f5112f97e6a7ea88dff7b7c81ceb9acd3b76a63cdc66f579400b9dd4a19ce908cd4037dbe8a98ae7581d8e51451426527f2f401f46ef83866a5b8c2744d1d
diff --git a/net-analyzer/scapy/scapy-2.4.3_rc3.ebuild b/net-analyzer/scapy/scapy-2.4.3_rc3.ebuild
new file mode 100644
index 000000000000..25877178edf3
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.3_rc3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}