summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-29 16:16:25 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-29 16:16:25 +0100
commit3856afddab4496750121131c622907c21235343e (patch)
tree7295ae69cd735f2d394d17c2545a95a868bacf3e /net-analyzer
parentdev-python/ipywidgets: Switch to PEP 517 build (diff)
downloadgentoo-3856afddab4496750121131c622907c21235343e.tar.gz
gentoo-3856afddab4496750121131c622907c21235343e.tar.bz2
gentoo-3856afddab4496750121131c622907c21235343e.zip
net-analyzer/snortsam: update EAPI 5 -> 7
Closes: https://bugs.gentoo.org/832319 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snortsam/snortsam-2.70-r1.ebuild (renamed from net-analyzer/snortsam/snortsam-2.70.ebuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.70.ebuild b/net-analyzer/snortsam/snortsam-2.70-r1.ebuild
index f32b3f6db2ed..d900b52d06f6 100644
--- a/net-analyzer/snortsam/snortsam-2.70.ebuild
+++ b/net-analyzer/snortsam/snortsam-2.70-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch flag-o-matic toolchain-funcs vcs-clean
+inherit flag-o-matic toolchain-funcs vcs-clean
DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
HOMEPAGE="http://www.snortsam.net/"
@@ -15,8 +15,10 @@ SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
IUSE="debug"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ default
ecvs_clean
}
@@ -31,14 +33,13 @@ src_compile() {
src_install() {
dobin snortsam
- find "${S}" -depth -type f -name "*.asc" -exec rm -f {} \;
- dodoc docs/* conf/*
+
+ find . -depth -type f -name '*.asc' -delete || die
+ dodoc -r docs/. conf/.
}
pkg_postinst() {
- echo
elog "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
elog "Read the INSTALL file to configure snort for snortsam, and configure"
elog "snortsam for your particular firewall."
- echo
}