summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2023-12-06 21:00:54 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-01 10:28:37 +0200
commit0925da33135f07b619aa49dc184d632048c2ae06 (patch)
tree10aab5f76f10884271c697a99e2342c8643b5229 /net-analyzer
parentapp-crypt/loop-aes-losetup: add 2.39.2 (diff)
downloadgentoo-0925da33135f07b619aa49dc184d632048c2ae06.tar.gz
gentoo-0925da33135f07b619aa49dc184d632048c2ae06.tar.bz2
gentoo-0925da33135f07b619aa49dc184d632048c2ae06.zip
net-analyzer/nikto: version bump to 2.5.0
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/34151 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nikto/Manifest1
-rw-r--r--net-analyzer/nikto/nikto-2.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index f62b90e4f8f1..c0a859172b2f 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1 +1,2 @@
DIST nikto-2.1.6_p20220602.tar.gz 455528 BLAKE2B 71094c786b274069eb17aac7d367bdc8535c7730afde7c7bf36d40719e2799561eb31ad9cc09ee39c47101880795eee0f1c46ca51c00644cdc23916033cc5f7e SHA512 5c8ce194951c10b8a5f4299e088928022193aa8ae7ed4fb6b9be76bcf03a405d776d6e30274f997ad9eeb95c012c7e09b6dec7cbecbe0ab4049e5d15529ae814
+DIST nikto-2.5.0.tar.gz 435886 BLAKE2B 66e3aaab87f031daeade1a46afce5f02b296a75a542c1f781140fa9e2a2b98c7a0051f0920cd109e35684c14e4137a59ac7f26a10d98dcaf663424ee1f5e10af SHA512 8561c048b2db9b91a53f389097f6f47b06b51d0bbb06d945a26463067a1b2192ae6ad086e8f14e8775827fa8075dabfff66df8c3f79915b7a2d4eaefb09894de
diff --git a/net-analyzer/nikto/nikto-2.5.0.ebuild b/net-analyzer/nikto/nikto-2.5.0.ebuild
new file mode 100644
index 000000000000..e7bb2ea3e968
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+SRC_URI="https://github.com/sullo/nikto/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ doman docs/nikto.1
+ dodoc docs/nikto.dtd
+ dodoc docs/nikto_schema.sql
+}