summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/xnetload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/xnetload')
-rw-r--r--net-analyzer/xnetload/Manifest1
-rw-r--r--net-analyzer/xnetload/metadata.xml5
-rw-r--r--net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild42
3 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/xnetload/Manifest b/net-analyzer/xnetload/Manifest
new file mode 100644
index 000000000000..bdb82789cee1
--- /dev/null
+++ b/net-analyzer/xnetload/Manifest
@@ -0,0 +1 @@
+DIST xnetload-1.11.3.tar.gz 24551 SHA256 518f6bd138b9d414865aa068ca7110de8b6d6cccde24e5deda8a8c534087a299 SHA512 2008102c132ee96b12251b7c2475efcae7926bb16ba032f75d6be42650785fb707bed3696586369c04bb0e9434ee7854de585e7a015f1a15037a7f30c86036b7 WHIRLPOOL d64db168de3626c60388c5b457602c9d4a31affae445efcbae3dea67e43d5a648c540187a7cbbfcefbad4acfae65428eb115f6a7e100d4ba3d48cd684d010bdc
diff --git a/net-analyzer/xnetload/metadata.xml b/net-analyzer/xnetload/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/xnetload/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild b/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild
new file mode 100644
index 000000000000..6b3ef4dcc97e
--- /dev/null
+++ b/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="displays a count and a graph of the traffic over a specified network connection"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.xs4all.nl/~rsmith/software/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS = -pipe -O2 -Wall:CFLAGS += -Wall:' \
+ -e 's:LFLAGS = -s -pipe:LFLAGS = $(LDFLAGS):' \
+ -e 's:gcc -MM:$(CC) -MM:' \
+ -e 's:/usr/X11R6:/usr:g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin xnetload
+ doman xnetload.1
+ dodoc ChangeLog README
+ insinto /usr/share/X11/app-defaults/
+ doins XNetload
+}