summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 00:36:30 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:12 +0000
commit5e1d2248de33e2a6213ca5f71746d8fa4b70551f (patch)
treeb75c1e66dac6f05fbe158d955e78d7df55c0c786 /net-analyzer/upnpscan
parentmedia-libs/libtaginfo: port to EAPI 7 (diff)
downloadgentoo-5e1d2248de33e2a6213ca5f71746d8fa4b70551f.tar.gz
gentoo-5e1d2248de33e2a6213ca5f71746d8fa4b70551f.tar.bz2
gentoo-5e1d2248de33e2a6213ca5f71746d8fa4b70551f.zip
net-analyzer/upnpscan: port to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/upnpscan')
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4-r3.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/net-analyzer/upnpscan/upnpscan-0.4-r3.ebuild b/net-analyzer/upnpscan/upnpscan-0.4-r3.ebuild
index 91839f3352c1..b92dcbfb3960 100644
--- a/net-analyzer/upnpscan/upnpscan-0.4-r3.ebuild
+++ b/net-analyzer/upnpscan/upnpscan-0.4-r3.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools
-inherit autotools-utils
-
-DESCRIPTION="Scans the network for UPNP capable devices"
+DESCRIPTION="Scans the network for UPnP capable devices"
HOMEPAGE="http://www.cqure.net/wp/upnpscan/"
SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-S=${WORKDIR}/${PN}
-
DOCS=( AUTHORS ChangeLog NEWS README TODO )
-PATCHES=( "${FILESDIR}"/${P}-r2-cflags.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-r2-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}