summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-06 23:30:46 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-06 23:30:46 +0100
commit4d7f504c525b7e8adf94e29e8f3162f606f5c7d4 (patch)
treedc237434cfe5d25399f65373c9fc06e6446d8137 /net-analyzer/ttcp
parentnet-analyzer/tcpreen: update EAPI 6 -> 8 (diff)
downloadgentoo-4d7f504c525b7e8adf94e29e8f3162f606f5c7d4.tar.gz
gentoo-4d7f504c525b7e8adf94e29e8f3162f606f5c7d4.tar.bz2
gentoo-4d7f504c525b7e8adf94e29e8f3162f606f5c7d4.zip
net-analyzer/ttcp: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/ttcp')
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r3.ebuild (renamed from net-analyzer/ttcp/ttcp-1.12-r2.ebuild)32
1 files changed, 21 insertions, 11 deletions
diff --git a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
index 6ef77f5b49cc..bd4b1e8b315a 100644
--- a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
+++ b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
@@ -1,26 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="Tool to test TCP and UDP throughput"
HOMEPAGE="
http://ftp.arl.mil/~mike/ttcp.html
- http://www.netcore.fi/pekkas/linux/ipv6/
-"
+ http://www.netcore.fi/pekkas/linux/ipv6/"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~jsmolic/distfiles/${P}.c"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-SRC_URI="
- mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~jsmolic/distfiles/${P}.c
-"
+
+src_prepare() {
+ mv "${DISTDIR}"/${P}.c ${PN}.c || die
+ default
+}
+
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
+ emake ttcp
}
src_install() {
- dobin ${PN}
- newman sgi-${PN}.1 ${PN}.1
+ dobin ttcp
+ newman sgi-ttcp.1 ttcp.1
}