summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/thrulay
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/thrulay')
-rw-r--r--net-analyzer/thrulay/Manifest1
-rw-r--r--net-analyzer/thrulay/files/thrulayd-conf.d9
-rw-r--r--net-analyzer/thrulay/files/thrulayd-init.d22
-rw-r--r--net-analyzer/thrulay/metadata.xml10
-rw-r--r--net-analyzer/thrulay/thrulay-0.9-r1.ebuild31
5 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/thrulay/Manifest b/net-analyzer/thrulay/Manifest
new file mode 100644
index 000000000000..ea12720a5892
--- /dev/null
+++ b/net-analyzer/thrulay/Manifest
@@ -0,0 +1 @@
+DIST thrulay-0.9.tar.gz 370312 SHA256 373d5613dfe371f6b4f48fc853f6c27701b2981ba4100388c9881cb802d1780d SHA512 9655ef37f6ef3ba51a2fadacf08978fb1c284af6b571dbf76c44e5582bf705bec08170b3b2cc69512b8327485dfd3f758ed2addf510a075558aea70eb4779a6f WHIRLPOOL 224cab8b044d09f2f8ce1f2cece990a6d08fc708596a02509edfaa0a38758d3716235fe1fee55a849f3d180a8acb6fc87499c9769ee8b2931d2d82b0fd03a2a8
diff --git a/net-analyzer/thrulay/files/thrulayd-conf.d b/net-analyzer/thrulay/files/thrulayd-conf.d
new file mode 100644
index 000000000000..bf14b09dafb7
--- /dev/null
+++ b/net-analyzer/thrulay/files/thrulayd-conf.d
@@ -0,0 +1,9 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# The default window size is 4194304 bytes
+#THRULAYD_WINDOW="4194304"
+
+# By default, thrulayd will listen on 5003/tcp
+#THRULAYD_PORT="5003"
diff --git a/net-analyzer/thrulay/files/thrulayd-init.d b/net-analyzer/thrulay/files/thrulayd-init.d
new file mode 100644
index 000000000000..b791047d4ccb
--- /dev/null
+++ b/net-analyzer/thrulay/files/thrulayd-init.d
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+}
+
+start() {
+ [ -n "${THRULAYD_WINDOW}" ] && THRULAYD_OPTS="${THRULAYD_OPTS} -w${THRULAYD_WINDOW}"
+ [ -n "${THRULAYD_PORT}" ] && THRULAYD_OPTS="${THRULAYD_OPTS} -p${THRULAYD_PORT}"
+ ebegin "Starting thrulayd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/thrulayd -- ${THRULAYD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping thrulayd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/thrulayd
+ eend $?
+}
diff --git a/net-analyzer/thrulay/metadata.xml b/net-analyzer/thrulay/metadata.xml
new file mode 100644
index 000000000000..0759bb9a19dd
--- /dev/null
+++ b/net-analyzer/thrulay/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">thrulay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
new file mode 100644
index 000000000000..59059fea408a
--- /dev/null
+++ b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs autotools
+
+DESCRIPTION="Measure the capacity of a network by sending a bulk TCP stream over it"
+HOMEPAGE="http://www.internet2.edu/~shalunov/thrulay/"
+SRC_URI="http://www.internet2.edu/~shalunov/thrulay/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+DEPEND=""
+
+src_prepare() {
+ echo 'thrulay thrulayd: libthrulay.la' >>src/Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ #dobin src/thrulay || die "dobin failed"
+ #dosbin src/thrulayd || die "dosbin failed"
+ dodoc LICENSE README TODO doc/thrulay-protocol.txt || die "dodoc failed"
+ doman doc/thrulay*.[1-8] || die "doman failed"
+ newinitd "${FILESDIR}"/thrulayd-init.d thrulayd || die "newinitd failed"
+ newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd || die "newconfd failed"
+}