summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-12 23:46:06 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:54:40 +0200
commit02c3a4c5a5b82dce0637ef5f493dea9d9d1a0e9b (patch)
tree363deb4413aaae4d8b1cce6ac15d2685d0beece6 /net-analyzer/sguil-sensor
parentnet-analyzer/sguil-sensor: migrate to GLEP 81 (diff)
downloadgentoo-02c3a4c5a5b82dce0637ef5f493dea9d9d1a0e9b.tar.gz
gentoo-02c3a4c5a5b82dce0637ef5f493dea9d9d1a0e9b.tar.bz2
gentoo-02c3a4c5a5b82dce0637ef5f493dea9d9d1a0e9b.zip
net-analyzer/sguil-sensor: drop old version
Closes: https://bugs.gentoo.org/781359 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer/sguil-sensor')
-rw-r--r--net-analyzer/sguil-sensor/sguil-sensor-1.0.0-r1.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/net-analyzer/sguil-sensor/sguil-sensor-1.0.0-r1.ebuild b/net-analyzer/sguil-sensor/sguil-sensor-1.0.0-r1.ebuild
deleted file mode 100644
index 7007abd7517f..000000000000
--- a/net-analyzer/sguil-sensor/sguil-sensor-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit user
-
-MY_PV="${PV/_p/p}"
-DESCRIPTION="Sensor part of sguil Network Security Monitoring"
-HOMEPAGE="https://github.com/bammv/sguil"
-SRC_URI="https://github.com/bammv/sguil/archive/v${PV}.tar.gz -> ${P/-sensor}.tar.gz"
-
-LICENSE="GPL-3 GPL-2+ QPL-1.0 GPL-2" # GPL-2 for init script
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-lang/tcl-8.3:0=[-threads]
- >=dev-tcltk/tclx-8.3
- dev-tcltk/tls
- >=net-analyzer/barnyard-0.2.0-r1
- >=net-analyzer/snort-2.4.1-r1
- dev-ml/pcre-ocaml
- net-analyzer/sancp
-"
-
-S="${WORKDIR}/sguil-${MY_PV}"
-
-pkg_setup() {
- enewgroup sguil
- enewuser sguil -1 -1 /var/lib/sguil sguil
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e "s:gateway:${HOSTNAME}:" \
- -e 's:/snort_data:/var/lib/sguil:' \
- -e 's:DAEMON 0:DAEMON 1:' \
- -e 's:DEBUG 1:DEBUG 0:g' \
- sensor/sensor_agent.conf || die
-
- sed -i \
- -e 's:/var/run/sensor_agent.pid:/run/sguil-sensor.pid:' \
- sensor/sensor_agent.tcl || die
-}
-
-src_install() {
- dodoc doc/*
-
- dobin sensor/sensor_agent.tcl
-
- newinitd "${FILESDIR}/log_packets.initd" log_packets
- newinitd "${FILESDIR}/sensor_agent.initd" sensor_agent
- newconfd "${FILESDIR}/log_packets.confd" log_packets
- insinto /etc/sguil
- doins sensor/sensor_agent.conf
-
- # Create the directory structure
- diropts -g sguil -o sguil
- keepdir /var/lib/sguil /var/lib/sguil/archive \
- "/var/lib/sguil/${HOSTNAME}" \
- "/var/lib/sguil/${HOSTNAME}/portscans" \
- "/var/lib/sguil/${HOSTNAME}/ssn_logs" \
- "/var/lib/sguil/${HOSTNAME}/dailylogs" \
- "/var/lib/sguil/${HOSTNAME}/sancp"
-
-}
-
-pkg_postinst() {
- elog
- elog "You should check /etc/sguil/sensor_agent.conf and"
- elog "/etc/init.d/logpackets and ensure that they are accurate"
- elog "for your environment. They should work providing that you"
- elog "are running the sensor on the same machine as the server."
- elog "This ebuild assumes that you are running a single sensor"
- elog "environment, if this is not the case then you must make sure"
- elog "to modify /etc/sguil/sensor_agent.conf and change the HOSTNAME variable."
- elog "You should crontab the /etc/init.d/log_packets script to restart"
- elog "each hour."
- elog
-}