summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch')
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch b/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch
new file mode 100644
index 000000000000..ddc0ca8ec4eb
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch
@@ -0,0 +1,102 @@
+--- a/configure.in
++++ b/configure.in
+@@ -41,7 +41,7 @@
+ CFLAGS="${CFLAGS} -Wextra -Wno-unused-parameter"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_extra_warnings="yes"],[have_extra_warnings="no"])
+ AC_MSG_RESULT($have_extra_warnings)
+-if test "$have_extra_warnings" == "no" ; then
++if test "$have_extra_warnings" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -50,7 +50,7 @@
+ CFLAGS="${CFLAGS} -Werror=implicit-function-declaration"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_implicit_function_declaration="yes"],[have_implicit_function_declaration="no"])
+ AC_MSG_RESULT($have_implicit_function_declaration)
+-if test "$have_implicit_function_declaration" == "no" ; then
++if test "$have_implicit_function_declaration" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -59,7 +59,7 @@
+ CFLAGS="${CFLAGS} -Werror=format"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_error_format="yes"],[have_error_format="no"])
+ AC_MSG_RESULT($have_error_format)
+-if test "$have_error_format" == "no" ; then
++if test "$have_error_format" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -93,7 +93,7 @@
+ [],[with_gd=check])
+ if ( test "x$with_gd" != "xno" ) ; then
+ AC_CHECK_HEADERS(gd.h gdfontl.h gdfontt.h gdfonts.h gdfontmb.h gdfontg.h)
+- if ( test "x$ac_cv_header_gd_h" == "xyes" ) ; then
++ if ( test "x$ac_cv_header_gd_h" = "xyes" ) ; then
+ AC_CHECK_LIB(gd, gdImagePng,LIBS="-lgd ${LIBS}"; HAVE_GD_LIB="yes", HAVE_GD_LIB="")
+ if ( test "x$HAVE_GD_LIB" != "xyes" ) ; then
+ AC_MSG_ERROR([ligbd is required to compile sarg with gd])
+@@ -137,7 +137,7 @@
+ [],[with_pcre=check])
+ if ( test "x$with_pcre" != "xno" ) ; then
+ AC_CHECK_HEADERS(pcre.h)
+- if ( test "x$ac_cv_header_pcre_h" == "xyes" ) ; then
++ if ( test "x$ac_cv_header_pcre_h" = "xyes" ) ; then
+ LIBS="$LIBS $(pcre-config --libs)"
+ CFLAGS="$CFLAGS $(pcre-config --cflags)"
+ else
+@@ -243,7 +243,7 @@
+ fi
+ ],[FONTDIR="${datarootdir}/sarg/fonts"])
+ if test "$FONTDIR" ; then
+- if test "x$prefix" == "xNONE" ; then
++ if test "x$prefix" = "xNONE" ; then
+ tempfullpath=`prefix=$ac_default_prefix ; eval "echo $FONTDIR"`
+ else
+ tempfullpath=`eval "echo $FONTDIR"`
+@@ -261,7 +261,7 @@
+ IMAGEDIR=$enableval
+ fi
+ ],[IMAGEDIR="${datarootdir}/sarg/images"])
+-if test "x$prefix" == "xNONE" ; then
++if test "x$prefix" = "xNONE" ; then
+ tempfullpath=`prefix=$ac_default_prefix ; eval "echo $IMAGEDIR"`
+ else
+ tempfullpath=`eval "echo $IMAGEDIR"`
+@@ -286,7 +286,7 @@
+ CFLAGS="${CFLAGS} -Wformat -Werror=format-security"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_format_security="yes"],[have_format_security="no"])
+ AC_MSG_RESULT($have_format_security)
+- if test "$have_format_security" == "no" ; then
++ if test "$have_format_security" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -295,7 +295,7 @@
+ CFLAGS="${CFLAGS} -Wempty-body"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_empty_body="yes"],[have_empty_body="no"])
+ AC_MSG_RESULT($have_empty_body)
+- if test "$have_empty_body" == "no" ; then
++ if test "$have_empty_body" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+ fi
+@@ -367,14 +367,14 @@
+ AC_CONFIG_FILES([Makefile po/Makefile.in])
+ AC_OUTPUT
+
+-if ( test "x$gd_status" == "xdisabled" ) ; then
++if ( test "x$gd_status" = "xdisabled" ) ; then
+ AC_MSG_NOTICE([Not building with gd as requested on the configuration command line])
+-elif ( test "x$gd_status" == "xnot found" ) ; then
++elif ( test "x$gd_status" = "xnot found" ) ; then
+ AC_MSG_NOTICE([gd.h was not found so the graphs won't be available in the report])
+ fi
+
+-if ( test "x$pcre_status" == "xdisabled" ) ; then
++if ( test "x$pcre_status" = "xdisabled" ) ; then
+ AC_MSG_NOTICE([Not building with pcre as requested on the configuration command line])
+-elif ( test "x$pcre_status" == "xnot found" ) ; then
++elif ( test "x$pcre_status" = "xnot found" ) ; then
+ AC_MSG_NOTICE([pcre.h was not found so the regexp won't be available in the hostalias])
+ fi