summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/openbsd-netcat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/openbsd-netcat')
-rw-r--r--net-analyzer/openbsd-netcat/Manifest1
-rw-r--r--net-analyzer/openbsd-netcat/metadata.xml11
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild69
3 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/Manifest b/net-analyzer/openbsd-netcat/Manifest
new file mode 100644
index 000000000000..8edf5f99f3e2
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/Manifest
@@ -0,0 +1 @@
+DIST nc-1.84-22.el6.src.rpm 62570 SHA256 8aa023a96a11f47fbaccda332f7e2c73697c271d2bd25b2485470d288d0db844 SHA512 a02f5a42e0db0aeff95a06964d6b9ccfa21d659ca67505d19c724966edbca42446ac4048339def769139ca6ae145cdc75e9908f12b21449bc9d748d3cac39094 WHIRLPOOL fb4b822b88fdf0097781ff8f23489e4300563e3c6f655b00519a2ced93f17cd433d5f3acf2cd66a7f97e4b3755838c9dc8619e0c1e5fbc54136a33212a8c7613
diff --git a/net-analyzer/openbsd-netcat/metadata.xml b/net-analyzer/openbsd-netcat/metadata.xml
new file mode 100644
index 000000000000..2eb55f5f9145
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+</maintainer>
+<longdescription lang="en">
+ This package provides the openbsd linux port of netcat.
+</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild
new file mode 100644
index 000000000000..219eb4ab613f
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.84.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs rpm
+
+DESCRIPTION="the OpenBSD network swiss army knife"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/"
+SRC_URI="ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/nc-1.84-22.el6.src.rpm"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static"
+
+DEPEND="dev-libs/glib:2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/nc
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_prepare() {
+ epatch "../nc-1.84-glib.patch"
+ epatch "../nc-1.78-pollhup.patch"
+ epatch "../nc-1.82-reuseaddr.patch"
+ epatch "../nc-gcc_signess.patch"
+ epatch "../nc-1.84-connect_with_timeout.patch"
+ epatch "../nc-1.84-udp_stop.patch"
+ epatch "../nc-1.84-udp_port_scan.patch"
+ epatch "../nc-1.84-crlf.patch"
+ epatch "../nc-1.84-verb.patch"
+ epatch "../nc-1.84-man.patch"
+ epatch "../nc-1.84-gcc4.3.patch"
+ epatch "../nc-1.84-efficient_reads.patch"
+ epatch "../nc-1.84-verbose-segfault.patch"
+
+ # avoid name conflict against net-analyzer/netcat
+ mv nc.1 nc.openbsd.1
+}
+
+src_compile() {
+ use static && export STATIC="-static"
+ COMPILER=$(tc-getCC)
+ ${COMPILER} ${CFLAGS} netcat.c atomicio.c socks.c \
+ $(pkg-config --cflags --libs glib-2.0) \
+ ${LDFLAGS} -o nc.openbsd || die
+}
+
+src_install() {
+ dobin nc.openbsd
+ dodoc README*
+ doman nc.openbsd.1
+ docinto scripts
+ dodoc scripts/*
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "FO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}