summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-01-02 10:00:37 -0500
committerCraig Andrews <candrews@gentoo.org>2024-01-02 10:00:37 -0500
commita9e7c16c506d4d2f59ffc6a82fc5f0b279bf5619 (patch)
treef3ddb7f4d472331b7a15791a54374ae17c9f3f31 /net-analyzer/netdata
parentdev-libs/libfmt: add 10.2.0 (diff)
downloadgentoo-a9e7c16c506d4d2f59ffc6a82fc5f0b279bf5619.tar.gz
gentoo-a9e7c16c506d4d2f59ffc6a82fc5f0b279bf5619.tar.bz2
gentoo-a9e7c16c506d4d2f59ffc6a82fc5f0b279bf5619.zip
net-analyzer/netdata: fix build failure when USE="-dbengine"
Closes: https://bugs.gentoo.org/919712 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/files/netdata-1.44.0-dbengine.patch47
-rw-r--r--net-analyzer/netdata/netdata-1.44.0.ebuild6
2 files changed, 52 insertions, 1 deletions
diff --git a/net-analyzer/netdata/files/netdata-1.44.0-dbengine.patch b/net-analyzer/netdata/files/netdata-1.44.0-dbengine.patch
new file mode 100644
index 000000000000..3119094f64bc
--- /dev/null
+++ b/net-analyzer/netdata/files/netdata-1.44.0-dbengine.patch
@@ -0,0 +1,47 @@
+From ee6c0bcb7f0bfe6440dd7c4c52dca87486abc181 Mon Sep 17 00:00:00 2001
+From: Stelios Fragkakis <52996999+stelfrag@users.noreply.github.com>
+Date: Wed, 20 Dec 2023 21:54:17 +0200
+Subject: [PATCH] Fix compilation error when using --disable-dbengine
+
+---
+ daemon/global_statistics.c | 2 ++
+ daemon/main.c | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/daemon/global_statistics.c b/daemon/global_statistics.c
+index 8392a3c88e08d..6e286b18a7220 100644
+--- a/daemon/global_statistics.c
++++ b/daemon/global_statistics.c
+@@ -857,6 +857,7 @@ static void global_statistics_charts(void) {
+
+ // ----------------------------------------------------------------
+
++#ifdef ENABLE_DBENGINE
+ if (tier_page_type[0] == PAGE_GORILLA_METRICS)
+ {
+ static RRDSET *st_tier0_gorilla_pages = NULL;
+@@ -918,6 +919,7 @@ static void global_statistics_charts(void) {
+
+ rrdset_done(st_tier0_compression_info);
+ }
++#endif
+ }
+
+ // ----------------------------------------------------------------------------
+diff --git a/daemon/main.c b/daemon/main.c
+index fc15f0c9dfc52..7c7452c4aa055 100644
+--- a/daemon/main.c
++++ b/daemon/main.c
+@@ -1502,11 +1502,11 @@ int main(int argc, char **argv) {
+ #ifdef ENABLE_DBENGINE
+ char* createdataset_string = "createdataset=";
+ char* stresstest_string = "stresstest=";
+-#endif
+
+ if(strcmp(optarg, "pgd-tests") == 0) {
+ return pgd_test(argc, argv);
+ }
++#endif
+
+ if(strcmp(optarg, "sqlite-meta-recover") == 0) {
+ sql_init_database(DB_CHECK_RECOVER, 0);
diff --git a/net-analyzer/netdata/netdata-1.44.0.ebuild b/net-analyzer/netdata/netdata-1.44.0.ebuild
index 120388949957..6149a81fb3ac 100644
--- a/net-analyzer/netdata/netdata-1.44.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.44.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -84,6 +84,10 @@ FILECAPS=(
'usr/libexec/netdata/plugins.d/debugfs.plugin'
)
+PATCHES=(
+ "${FILESDIR}/${P}-dbengine.patch"
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
linux-info_pkg_setup