summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-16 11:24:55 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-16 11:36:17 +0200
commitdc6e9f6e27d40d4f52bd5961a0a4e0034779bf37 (patch)
treede1659d0c667786d8182c45c57ed12b1b64ae432 /net-analyzer/net-snmp
parentdev-python/dask: Bump to 2.23.0 (diff)
downloadgentoo-dc6e9f6e27d40d4f52bd5961a0a4e0034779bf37.tar.gz
gentoo-dc6e9f6e27d40d4f52bd5961a0a4e0034779bf37.tar.bz2
gentoo-dc6e9f6e27d40d4f52bd5961a0a4e0034779bf37.zip
net-analyzer/net-snmp: Run poor person's distclean
The source tarball distributed through Github and Sourceforge contains amd64 specific binaries that should have been removed before packaging. While there, run `make sedscript` before other build targets. Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.9.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-5.9.ebuild b/net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild
index 5f50c7d5aff0..09e90cd56245 100644
--- a/net-analyzer/net-snmp/net-snmp-5.9.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.9-r1.ebuild
@@ -85,6 +85,9 @@ pkg_setup() {
}
src_prepare() {
+ find -type d -name .libs -depth -exec rm -r {} \; || die
+ find -type f -name '*.o' -o -name '*.lo' -exec rm {} \; || die
+
# snmpconf generates config files with proper selinux context
use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
@@ -138,6 +141,8 @@ src_configure() {
}
src_compile() {
+ emake sedscript
+
local subdir
for subdir in snmplib agent/mibgroup agent apps .; do
emake OTHERLDFLAGS="${LDFLAGS}" -C ${subdir} all