summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-06 22:25:33 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-06 22:25:33 +0100
commit5fe6d7a57c71ca4098559207fb78f589e966a708 (patch)
tree5c12c3d6e169cfc2d2efdcc38a0c3fcc784679f3 /net-analyzer/ndoutils
parentnet-analyzer/ifmetric: update EAPI 6 -> 8 (diff)
downloadgentoo-5fe6d7a57c71ca4098559207fb78f589e966a708.tar.gz
gentoo-5fe6d7a57c71ca4098559207fb78f589e966a708.tar.bz2
gentoo-5fe6d7a57c71ca4098559207fb78f589e966a708.zip
net-analyzer/ndoutils: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/ndoutils')
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild (renamed from net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild)59
1 files changed, 27 insertions, 32 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild b/net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild
index 784309fee43a..044cb36975f4 100644
--- a/net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild
+++ b/net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit systemd
DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
HOMEPAGE="https://www.nagios.org/"
SRC_URI="https://github.com/NagiosEnterprises/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="GPL-2"
SLOT="0"
@@ -14,30 +16,19 @@ KEYWORDS="~amd64 ~ppc ~x86"
# We require the "nagios" user from net-analyzer/nagios-core at build
# time.
-DEPEND="dev-db/mysql-connector-c
+DEPEND="
+ dev-db/mysql-connector-c
dev-perl/DBD-mysql
dev-perl/DBI
>=net-analyzer/nagios-core-4.4.5"
RDEPEND="${DEPEND}
virtual/mysql"
-S="${WORKDIR}/${PN}-${P}"
-
-DOCS=(
- Changelog
- README
- THANKS
- TODO
- UPGRADING
- "docs/NDOUTILS DB Model.pdf"
- "docs/NDOUtils Documentation.pdf"
-)
-
PATCHES=(
- "${FILESDIR}/format-security.patch"
- "${FILESDIR}/ndoutils-2.0.0-asprintf.patch"
- "${FILESDIR}/sample-config-piddir.patch"
- "${FILESDIR}/openrc-init.patch"
+ "${FILESDIR}"/format-security.patch
+ "${FILESDIR}"/ndoutils-2.0.0-asprintf.patch
+ "${FILESDIR}"/sample-config-piddir.patch
+ "${FILESDIR}"/openrc-init.patch
)
src_configure() {
@@ -58,34 +49,38 @@ src_compile() {
# Avoid "emake all" so that we don't build the stuff for nagios-2.x
# and nagios-3.x, some of which throws QA warnings. We don't use it
# anyway.
- pushd src
- emake file2sock log2ndo ndo2db-4x ndomod-4x.o sockdebug
- popd
+ emake -C src file2sock log2ndo ndo2db-4x ndomod-4x.o sockdebug
}
src_install() {
+ # The documentation isn't installed by the build system
+ HTML_DOCS=( docs/html/. )
default
+
+ dodoc Changelog UPGRADING \
+ "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+ systemd_newunit startup/default-service ndoutils.service
+
insinto /etc/nagios
newins config/ndo2db.cfg-sample ndo2db.cfg
newins config/ndomod.cfg-sample ndomod.cfg
- newinitd "startup/openrc-init" ndo2db
- newconfd "startup/openrc-conf" ndo2db
- systemd_newunit "startup/default-service" "${PN}.service"
+ newinitd startup/openrc-init ndo2db
+ newconfd startup/openrc-conf ndo2db
- # The documentation isn't installed by the build system
- dodoc -r docs/html
-
- insinto "/usr/share/${PN}"
+ insinto /usr/share/ndoutils
doins -r db
# These need to be executable...
- exeinto "/usr/share/${PN}/db"
+ exeinto /usr/share/ndoutils/db
doexe db/{installdb,prepsql,upgradedb}
# Use symlinks because the installdb/upgradedb scripts use relative
# paths to the SQL queries.
- dosym "../share/${PN}/db/installdb" /usr/bin/ndoutils-installdb
- dosym "../share/${PN}/db/upgradedb" /usr/bin/ndoutils-upgradedb
+ dosym ../share/ndoutils/db/installdb /usr/bin/ndoutils-installdb
+ dosym ../share/ndoutils/db/upgradedb /usr/bin/ndoutils-upgradedb
+
+ keepdir /var/lib/nagios
}
pkg_postinst() {