summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 18:01:54 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 18:01:54 +0200
commit7ccf9b584ab1d21e6b52143dd096a64b4d74e9d7 (patch)
treedef5640d61570c499f9f644d1b007843a3e8e37f /net-analyzer/nagios-plugin-check_raid
parentnet-analyzer/nagios-plugin-check_raid: drop 4.0.8-r2 (diff)
downloadgentoo-7ccf9b584ab1d21e6b52143dd096a64b4d74e9d7.tar.gz
gentoo-7ccf9b584ab1d21e6b52143dd096a64b4d74e9d7.tar.bz2
gentoo-7ccf9b584ab1d21e6b52143dd096a64b4d74e9d7.zip
net-analyzer/nagios-plugin-check_raid: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-plugin-check_raid')
-rw-r--r--net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r3.ebuild (renamed from net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r2.ebuild)49
1 files changed, 25 insertions, 24 deletions
diff --git a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r2.ebuild b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r3.ebuild
index d0caa68e4912..e5295fefced0 100644
--- a/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r2.ebuild
+++ b/net-analyzer/nagios-plugin-check_raid/nagios-plugin-check_raid-4.0.10-r3.ebuild
@@ -1,52 +1,53 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit perl-module
-DESCRIPTION="Nagios/Icinga plugin to check current server's RAID status"
-HOMEPAGE="https://github.com/glensc/nagios-plugin-check_raid"
#COMMIT=""
MY_PV="${COMMIT:-${PV}}"
MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Nagios/Icinga plugin to check current server's RAID status"
+HOMEPAGE="https://github.com/glensc/nagios-plugin-check_raid"
SRC_URI="https://github.com/glensc/nagios-plugin-check_raid/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE="3ware aacraid dmraid hpa hpsa megaraid-sas mpt mpt-sas2"
-DEPEND="dev-perl/Monitoring-Plugin
- dev-perl/Module-Pluggable"
+DEPEND="
+ dev-perl/Monitoring-Plugin
+ dev-perl/Module-Pluggable"
RDEPEND="${DEPEND}
- sys-apps/smartmontools
- sys-fs/lsscsi
- 3ware? ( sys-block/tw_cli )
- aacraid? ( sys-block/arcconf )
- dmraid? ( sys-fs/dmraid )
- hpa? ( sys-block/hpacucli )
- hpsa? ( sys-apps/cciss_vol_status )
- megaraid-sas? ( sys-block/megacli )
- mpt-sas2? ( sys-block/sas2ircu )
- mpt? ( sys-block/mpt-status )
-"
-
-S="${WORKDIR}/${MY_P}"
+ sys-apps/smartmontools
+ sys-fs/lsscsi
+ 3ware? ( sys-block/tw_cli )
+ aacraid? ( sys-block/arcconf )
+ dmraid? ( sys-fs/dmraid )
+ hpa? ( sys-block/hpacucli )
+ hpsa? ( sys-apps/cciss_vol_status )
+ megaraid-sas? ( sys-block/megacli )
+ mpt-sas2? ( sys-block/sas2ircu )
+ mpt? ( sys-block/mpt-status )"
src_prepare() {
- # Upstream has a custom Makefile that is meant to build bundles.
- #mv -f Makefile Makefile.upstream || die
- sed -i '/CPANfile/d' Makefile.PL || die
default
+
+ # Upstream has a custom Makefile that is meant to build bundles
+ sed -i '/CPANfile/d' Makefile.PL || die
}
src_install() {
default
- plugindir="/usr/$(get_libdir)/nagios/plugins"
- dodir "${plugindir}"
- mv -f "${ED}"/usr/bin/check_raid.pl "${ED}"/"${plugindir}" || die
dodoc README.md CHANGELOG.md CONTRIBUTING.md check_raid.cfg
+
+ local plugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${plugindir}"
+ mv -f "${ED}"/usr/bin/check_raid.pl "${ED}/${plugindir}" || die
}
pkg_postinst() {