summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-02-25 11:50:00 -0500
committerRick Farina <zerochaos@gentoo.org>2021-02-25 11:50:12 -0500
commitf0ee4c5d75815e5c06c8e57d9d2cea2c788038dd (patch)
treed2580581de2471748c0077d6053cdc168730174e /net-analyzer/multimon-ng
parentmedia-libs/noise-suppression-for-voice: bump (diff)
downloadgentoo-f0ee4c5d75815e5c06c8e57d9d2cea2c788038dd.tar.gz
gentoo-f0ee4c5d75815e5c06c8e57d9d2cea2c788038dd.tar.bz2
gentoo-f0ee4c5d75815e5c06c8e57d9d2cea2c788038dd.zip
net-analyzer/multimon-ng: bump
add missing pdep Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-analyzer/multimon-ng')
-rw-r--r--net-analyzer/multimon-ng/Manifest2
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild (renamed from net-analyzer/multimon-ng/multimon-ng-1.1.8.ebuild)5
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-9999.ebuild5
3 files changed, 7 insertions, 5 deletions
diff --git a/net-analyzer/multimon-ng/Manifest b/net-analyzer/multimon-ng/Manifest
index 59bc5904a3ff..cea5f08e8465 100644
--- a/net-analyzer/multimon-ng/Manifest
+++ b/net-analyzer/multimon-ng/Manifest
@@ -1 +1 @@
-DIST multimon-ng-1.1.8.tar.gz 2430488 BLAKE2B 82bc0be58e2f7d596363fc916c11584cbd1335e7984194af22955587877ad1cba2a0cca819467061bb18b97ca70f5c2adfd73ccbf159fbc27348d59429959ada SHA512 9cf93362555e5dc465a9ec60dff27b9875879afd954e810069022b3c003eca4c3ab2a833f1c00fef877175bc72e2d378bbb53380ada54542ae29d257a7d2bd1b
+DIST multimon-ng-1.1.9.tar.gz 2433964 BLAKE2B c2d72ba3b19ba162cb6fa9b8c1a66d950f3ed0acb36117ce070fbb9ede1837225b7349f473477020eea0ba727b6ea088688dbfaa50257702f337f1270ff5a233 SHA512 a30d8933b6cd0150a24a70544c03fa418bb5bdb00ab5531692f7153b59593455a915078a7417fb08c815b140f4c25786a9c412503dc50bead54f9dda304c053e
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.1.8.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
index 6e71ce63712d..f2011e9ff0d2 100644
--- a/net-analyzer/multimon-ng/multimon-ng-1.1.8.ebuild
+++ b/net-analyzer/multimon-ng/multimon-ng-1.1.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
HOMEPAGE="https://github.com/EliasOenal/multimon-ng"
@@ -23,9 +23,10 @@ IUSE="pulseaudio X"
DEPEND="pulseaudio? ( media-sound/pulseaudio )
X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
+PDEPEND="media-sound/sox"
src_prepare() {
use pulseaudio || sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
use X || sed -i '/find_package( X11 )/d' CMakeLists.txt
- cmake-utils_src_prepare
+ cmake_src_prepare
}
diff --git a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
index 6e71ce63712d..f2011e9ff0d2 100644
--- a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
+++ b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
HOMEPAGE="https://github.com/EliasOenal/multimon-ng"
@@ -23,9 +23,10 @@ IUSE="pulseaudio X"
DEPEND="pulseaudio? ( media-sound/pulseaudio )
X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
+PDEPEND="media-sound/sox"
src_prepare() {
use pulseaudio || sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
use X || sed -i '/find_package( X11 )/d' CMakeLists.txt
- cmake-utils_src_prepare
+ cmake_src_prepare
}