summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 23:52:40 +0000
committerSam James <sam@gentoo.org>2021-03-15 23:52:40 +0000
commit616d0d9979b37aef780314853279f7de5827cd81 (patch)
tree8948afe20028d04f4db5f2673e1c0ca3ad9eff3b /net-analyzer/labrea
parentx11-misc/xlockmore: add 5.66 (diff)
downloadgentoo-616d0d9979b37aef780314853279f7de5827cd81.tar.gz
gentoo-616d0d9979b37aef780314853279f7de5827cd81.tar.bz2
gentoo-616d0d9979b37aef780314853279f7de5827cd81.zip
net-analyzer/labrea: fix libdir
Closes: https://bugs.gentoo.org/731172 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/labrea')
-rw-r--r--net-analyzer/labrea/files/labrea-2.5-libdir.patch26
-rw-r--r--net-analyzer/labrea/labrea-2.5_p1.ebuild14
2 files changed, 35 insertions, 5 deletions
diff --git a/net-analyzer/labrea/files/labrea-2.5-libdir.patch b/net-analyzer/labrea/files/labrea-2.5-libdir.patch
new file mode 100644
index 000000000000..039745205c3c
--- /dev/null
+++ b/net-analyzer/labrea/files/labrea-2.5-libdir.patch
@@ -0,0 +1,26 @@
+--- a/configure.in
++++ b/configure.in
+@@ -82,9 +82,9 @@ AC_ARG_WITH(libpcap,
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ PCAPINC="-I$withval/include"
+ if test -f $withval/lib/libwpcap.a; then
+- PCAPLIB="-L$withval/lib -lwpcap"
++ PCAPLIB="-L$withval/${libdir} -lwpcap"
+ else
+- PCAPLIB="-L$withval/lib -lpcap"
++ PCAPLIB="-L$withval/${libdir} -lpcap"
+ fi
+ else
+ AC_ERROR(pcap.h, net/bpf.h, or libpcap.a not found in $withval)
+@@ -94,9 +94,9 @@ AC_ARG_WITH(libpcap,
+ [ if test -f ${prefix}/include/pcap.h; then
+ PCAPINC="-I${prefix}/include"
+ if test -f ${prefix}/lib/libwpcap.a; then
+- PCAPLIB="-L${prefix}/lib -lwpcap"
++ PCAPLIB="-L${libdir} -lwpcap"
+ else
+- PCAPLIB="-L${prefix}/lib -lpcap"
++ PCAPLIB="-L${libdir} -lpcap"
+ fi
+ elif test -f /usr/include/pcap/pcap.h; then
+ PCAPINC="-I/usr/include/pcap"
diff --git a/net-analyzer/labrea/labrea-2.5_p1.ebuild b/net-analyzer/labrea/labrea-2.5_p1.ebuild
index 5fc9881601f9..a47abfc9e1a0 100644
--- a/net-analyzer/labrea/labrea-2.5_p1.ebuild
+++ b/net-analyzer/labrea/labrea-2.5_p1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="'Sticky' Honeypot and IDS"
HOMEPAGE="http://labrea.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_p*}-stable-${PV/*_p}.tar.gz"
+S="${WORKDIR}/${P/_p/-stable-}"
LICENSE="GPL-2"
SLOT="0"
@@ -16,15 +18,15 @@ DEPEND="
net-libs/libpcap
>=dev-libs/libdnet-1.7
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
DOCS=( AUTHORS ChangeLog README{,.first} TODO NEWS )
+
PATCHES=(
"${FILESDIR}"/${P/_p/-stable-}-incdir.patch
"${FILESDIR}"/${P/_p*}-pcap_open.patch
+ "${FILESDIR}"/${PN}-2.5-libdir.patch
)
-S=${WORKDIR}/${P/_p/-stable-}
src_prepare() {
default
@@ -32,6 +34,8 @@ src_prepare() {
# autotools will overwrite this with the generic version
mv INSTALL README.first || die
+ mv configure.{in,ac} || die
+
eautoreconf
}