summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-20 08:12:06 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-20 08:12:06 +0200
commitdc7f8fbc899a6ad6eda66f628a1334a82b64aa26 (patch)
treebfd9dad0a578a92a8b969c5e199bae743b823a78 /net-analyzer/cacti-spine
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-dc7f8fbc899a6ad6eda66f628a1334a82b64aa26.tar.gz
gentoo-dc7f8fbc899a6ad6eda66f628a1334a82b64aa26.tar.bz2
gentoo-dc7f8fbc899a6ad6eda66f628a1334a82b64aa26.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.1.13.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 30a21c13d61c..6357af7a3c71 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,3 +1,4 @@
DIST cacti-spine-0.8.8h.tar.gz 804951 SHA256 a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30 SHA512 6a7147ab645be44de0d330c7801e569705817da10bf6cedba82c712e1701ada8aa8924a6b3b063ea680e6af24f815d6767e8773ad7b8da212abfa082b4211bd4 WHIRLPOOL 36daed4986ca84883e51ab6b02ebb2ade00205c30705cfc94e73835bc2fc427a60a2dba9c7ca3665d0c0b2fca21afab77d94cde63b740f3734f9279c929cccaf
+DIST cacti-spine-1.1.13.tar.gz 801645 SHA256 900c5dd402b42042d960cc277d4bb5edc55e93b34e37ae79dac8cef2d8685641 SHA512 6ec5e629818ad274ee3864cbd1bfa70e35e6509e1dd0eb231da9889b3844e7e75d269c9d16d57796e75f36dfd204172c9d7e6843e0b06e3ac20bbf4f781b1b8c WHIRLPOOL 4d5875d4dedebcbd72d99ab06499411e398ed33a8ec7cae45b5528a1f234852897c4d761d58b76dbca19969f2aa051618cb07cec93e225620530aa2bf6bfeb19
DIST cacti-spine-1.1.7.tar.gz 801419 SHA256 97183529cdcd8446fbcb606710b6c0a7bd2f7166edbf910dc583e5a760ed2c5c SHA512 d62c6db176bd40a3a64b91acff512552ac7a3376701e84bc49e4ec345d0724a0c45905edb63bfe4f2bbb7878f90b2bca43d3b7531ea7d85a6975d81ad2de79eb WHIRLPOOL 99c0f9c5500170bba8e221ecc84b2de6efb547a6edba30c1c11f773ceab68ab5a5bc933328bda2fda461fd7483dcba881d794459ac60f9e25aed77b42bf41b65
DIST cacti-spine-1.1.9.tar.gz 801539 SHA256 1b93cd5572017a373b24a58ef6b82c4ada994784948493204f9957a45103c275 SHA512 ed4108fae139d1d85478b90bb03e47df6b27eb839104336c3f734bbae91113bee15be84de1da9a5f00bd278d71d72e7de7d24e2f495157a976a4faedfc52d7f0 WHIRLPOOL c1b98eeebbbddaed5920cd491a6535efbc799715cb5c3f1fbfe5483e7aeda30f443bae185cc1e9526ce9289890b76d19e24cf7835a3bb90a16659389dbaace08
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.1.13.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.1.13.ebuild
new file mode 100644
index 000000000000..34727025866f
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.1.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}