summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-19 03:34:35 +0100
committerSam James <sam@gentoo.org>2022-10-19 03:34:46 +0100
commit65ea27c50ef813e5aa0acaaf966d896ddcb56460 (patch)
tree817d3eb6326df545ae81dca2d8505e0ad5412345 /net-analyzer/authforce
parentapp-cdr/extract-xiso: add github upstream metadata (diff)
downloadgentoo-65ea27c50ef813e5aa0acaaf966d896ddcb56460.tar.gz
gentoo-65ea27c50ef813e5aa0acaaf966d896ddcb56460.tar.bz2
gentoo-65ea27c50ef813e5aa0acaaf966d896ddcb56460.zip
net-analyzer/authforce: fix build w/ Clang 16
Closes: https://bugs.gentoo.org/871222 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/authforce')
-rw-r--r--net-analyzer/authforce/authforce-0.9.9-r4.ebuild (renamed from net-analyzer/authforce/authforce-0.9.9-r3.ebuild)9
-rw-r--r--net-analyzer/authforce/files/authforce-0.9.9-Include-stdlib.h-for-free.patch16
2 files changed, 22 insertions, 3 deletions
diff --git a/net-analyzer/authforce/authforce-0.9.9-r3.ebuild b/net-analyzer/authforce/authforce-0.9.9-r4.ebuild
index 556c3128dad6..1c3be5b08d76 100644
--- a/net-analyzer/authforce/authforce-0.9.9-r3.ebuild
+++ b/net-analyzer/authforce/authforce-0.9.9-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="curl nls"
-RDEPEND="sys-libs/readline:0=
+RDEPEND="sys-libs/readline:=
curl? ( net-misc/curl )"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"
@@ -25,11 +25,14 @@ PATCHES=(
"${FILESDIR}"/${P}-fixes-for-Wall-warnings.patch
"${FILESDIR}"/${P}-fix-parsing-of-sample-config-file.patch
"${FILESDIR}"/${P}-fix-submit_dummy_list-re-declaration.patch
+ "${FILESDIR}"/${PN}-0.9.9-Include-stdlib.h-for-free.patch
)
src_prepare() {
default
- gunzip doc/${PN}.1.gz
+
+ gunzip doc/${PN}.1.gz || die
+
sed -i -e "s/${PN}.1.gz/${PN}.1/g" \
-e "s/\/mang/\/man1/g" doc/Makefile* || die
}
diff --git a/net-analyzer/authforce/files/authforce-0.9.9-Include-stdlib.h-for-free.patch b/net-analyzer/authforce/files/authforce-0.9.9-Include-stdlib.h-for-free.patch
new file mode 100644
index 000000000000..fec77215435c
--- /dev/null
+++ b/net-analyzer/authforce/files/authforce-0.9.9-Include-stdlib.h-for-free.patch
@@ -0,0 +1,16 @@
+From e5e62f92c53f5f8cca9380ad3225c84be5eec04f Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 19 Oct 2022 03:33:51 +0100
+Subject: [PATCH] Include <stdlib.h> for free()
+
+Bug: https://bugs.gentoo.org/871222
+--- a/src/debug.c
++++ b/src/debug.c
+@@ -3,6 +3,7 @@
+ #include <config.h>
+ #include <stdio.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+ #ifdef MEMWATCH
+ #include "memwatch.h"
+ #endif /* MEMWATCH*/