summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-07 20:03:52 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-07 23:18:39 -0400
commitd2e77ee9cec6ee8f70e1572e2a243f555c1241a3 (patch)
treea2e9af89c82ebf912084427a34cddab486095e3d /media-video
parentgnome-base/gnome-shell: backport fix for strict-aliasing with USE=pipewire (diff)
downloadgentoo-d2e77ee9cec6ee8f70e1572e2a243f555c1241a3.tar.gz
gentoo-d2e77ee9cec6ee8f70e1572e2a243f555c1241a3.tar.bz2
gentoo-d2e77ee9cec6ee8f70e1572e2a243f555c1241a3.zip
media-video/webcamoid: update live to build with upstream changes
Primarily, it has moved to Qt6 now. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/webcamoid/webcamoid-9999.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/media-video/webcamoid/webcamoid-9999.ebuild b/media-video/webcamoid/webcamoid-9999.ebuild
index c539d8831d38..c77abd8ab919 100644
--- a/media-video/webcamoid/webcamoid-9999.ebuild
+++ b/media-video/webcamoid/webcamoid-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,23 +24,16 @@ IUSE="alsa ffmpeg gstreamer jack libuvc oss portaudio pulseaudio qtaudio qtcamer
REQUIRED_USE="v4lutils? ( v4l )"
COMMON_DEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
+ dev-qt/qtbase:6[concurrent,dbus,gui,network,opengl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
ffmpeg? ( media-video/ffmpeg:= )
gstreamer? ( >=media-libs/gstreamer-1.6.0 )
jack? ( virtual/jack )
libuvc? ( media-libs/libuvc )
pulseaudio? ( media-libs/libpulse )
- qtaudio? ( dev-qt/qtmultimedia:5 )
- qtcamera? ( dev-qt/qtmultimedia:5 )
+ qtaudio? ( dev-qt/qtmultimedia:6 )
+ qtcamera? ( dev-qt/qtmultimedia:6 )
sdl? ( media-libs/libsdl2 )
v4l? ( media-libs/libv4l )
"
@@ -64,6 +57,7 @@ src_configure() {
"-DNOPIPEWIRE=1"
"-DNOPORTAUDIO=1" # PortAudio not packaged for gentoo
"-DNOALSA=$(usex alsa 0 1)"
+ "-DNOQTAUDIO=$(usex qtaudio 0 1)"
"-DNOQTCAMERA=$(usex qtcamera 0 1)"
"-DNOFFMPEG=$(usex ffmpeg 0 1)"
"-DNOGSTREAMER=$(usex gstreamer 0 1)"