summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2018-01-26 00:11:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-01-30 23:18:58 +0100
commitc3795d031a4b2bec97212a6a65a88390759b544a (patch)
treead6adfa1eeddddbf07596921eb64976e8fa91d83 /media-video
parentapp-misc/ddcutil: remove pedantic compiler flag (diff)
downloadgentoo-c3795d031a4b2bec97212a6a65a88390759b544a.tar.gz
gentoo-c3795d031a4b2bec97212a6a65a88390759b544a.tar.bz2
gentoo-c3795d031a4b2bec97212a6a65a88390759b544a.zip
media-video/syncplay: version bump to 1.5.1.
Closes: https://github.com/gentoo/gentoo/pull/6963
Diffstat (limited to 'media-video')
-rw-r--r--media-video/syncplay/Manifest1
-rw-r--r--media-video/syncplay/syncplay-1.5.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/syncplay/Manifest b/media-video/syncplay/Manifest
index 489af39aaaf8..4bbe1ba2982b 100644
--- a/media-video/syncplay/Manifest
+++ b/media-video/syncplay/Manifest
@@ -1,2 +1,3 @@
DIST syncplay-1.4.0.tar.gz 539743 BLAKE2B 52eeb80480783c827538aa9c7bde1bf9516ae1219600e6be42eb8e0477c2b6377e6b2d0e950bd83367cca55d8aad47bb756d820b795d3354465e3e4989aec1ea SHA512 2266ffafe3b15730a43e3ddd8aa24e99c65ce5a4e95d05bcac745262d310cb846c84c6e5bb061ebb96e89faa0f10e22aacee286db6cbe53cd5f521cb2e5eee1a
DIST syncplay-1.5.0.tar.gz 1588514 BLAKE2B 0f2bddf3500758c3081bdba993b21fe60a0d3af7081c5edd0f684e1d60a2a95edce133a597e79747350e681dd40768226226f0b26e295850a8c218107b1da3e9 SHA512 8a57add8a845c041c02147415fc4b7941a41edfb80fc037c3af4e246d9ca6391be9f3886407470b1b51b8783ad6306e42bb34991e7cbb08eea87e781e3cd2200
+DIST syncplay-1.5.1.tar.gz 1603524 BLAKE2B 0d7edb0c2129f67ce457cffb57f5600d0c0d6bee017119efc866d748f63e6e984becd21f88324e19dcac3f0ce52e2e2f1bf65326aab6237ea41b04bdecf26334 SHA512 8d7f99132b49148003dcdc83b5afc3158ebd7ad0b8a161229f8f576e7683e3c432d09793db071239e6344490f6e08d01c9061a32556b5bce6dcd68823b47a0cf
diff --git a/media-video/syncplay/syncplay-1.5.1.ebuild b/media-video/syncplay/syncplay-1.5.1.ebuild
new file mode 100644
index 000000000000..00a24344bbf1
--- /dev/null
+++ b/media-video/syncplay/syncplay-1.5.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="http://syncplay.pl"
+SRC_URI="https://github.com/Syncplay/syncplay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="+client +server gui vlc"
+REQUIRED_USE="vlc? ( client )
+ gui? ( client )
+ ${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+# TODO: investigate the possibility of enabling PyQt5 gui
+# possible licensing concerns
+RDEPEND="${PYTHON_DEPS}
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ gui? ( dev-python/pyside[${PYTHON_USEDEP}] )
+ vlc? ( media-video/vlc[lua] )"
+
+src_prepare() {
+ default
+ if ! use gui; then
+ sed -i 's/"noGui": False,/"noGui": True,/' \
+ syncplay/ui/ConfigurationGetter.py \
+ || die "Failed to patch ConfigurationGetter.py"
+ fi
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
+ use client && \
+ emake "${MY_MAKEOPTS[@]}" VLC_SUPPORT=$(usex vlc true false) install-client
+ use server && \
+ emake "${MY_MAKEOPTS[@]}" install-server
+}
+
+pkg_postinst() {
+ if use client; then
+ einfo "Syncplay supports the following players:"
+ einfo "media-video/mpv, media-video/mplayer2, media-video/vlc"
+ fi
+}