summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/vstrip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/vstrip')
-rw-r--r--media-video/vstrip/Manifest1
-rw-r--r--media-video/vstrip/files/vstrip-0.8f-gentoo.patch63
-rw-r--r--media-video/vstrip/metadata.xml12
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild39
4 files changed, 115 insertions, 0 deletions
diff --git a/media-video/vstrip/Manifest b/media-video/vstrip/Manifest
new file mode 100644
index 000000000000..36f10f24eae4
--- /dev/null
+++ b/media-video/vstrip/Manifest
@@ -0,0 +1 @@
+DIST vStrip_08f.zip 409157 RMD160 ad98ce87a97da98878711d5e14e9e33d270fce8f SHA1 5d8176b1c649188ab428513d0f30d837c8ae25ac SHA256 0813be0b20ab7eeacd7213df7fe1704ef6070471c953a705391d82bba78e8fff
diff --git a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
new file mode 100644
index 000000000000..77328b091247
--- /dev/null
+++ b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
@@ -0,0 +1,63 @@
+--- Makefile
++++ Makefile 2003-10-12 02:25:31.000000000 +0000
+@@ -4,7 +4,7 @@
+
+ ### Sources
+
+-SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c
++SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c dvd2avi_plugin.c
+
+ ### Objects and executables
+
+@@ -27,8 +27,8 @@
+
+ ### Details
+
+-vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o
+- $(CC) -g file_io.o in_buffer.o main.o parse_ifo.o vstrip.o -o vstrip
++vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o
++ $(CC) $(LDFLAGS) file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o -o vstrip -lm
+ file_io.o : s_types.h file_io.h file_io.c
+ in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c
+ main.o : s_types.h file_io.h vstrip.h main.c
+--- dvd2avi_plugin.c
++++ dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
+@@ -6,13 +6,17 @@
+
+ *************************************************************************/
+
++#include <string.h>
++#include <stdlib.h>
+ #include <stdio.h>
+-#include <io.h>
++#include <sys/io.h>
+ #include <fcntl.h>
+ #include "s_types.h"
+ #include "vstrip.h"
+ #include "dvd2avi_plugin.h"
+
++#define max(a,b) a < b ? b : a
++
+ bool dvd2avi_process(byte *data, tp_vs_streaminfo const si, void *user_data)
+ {
+ t_dvd2avi* d2v = (t_dvd2avi *)user_data;
+@@ -206,7 +210,7 @@
+ fp = _open(fname, _O_BINARY | _O_RDONLY); // check size
+ if (fp != -1)
+ {
+- __int64 fposition = _filelengthi64(fp);
++ __int64_t fposition = lseek64(fp, 0, SEEK_END);
+
+ lba = (dword)(fposition / fio_SECTOR_SIZE);
+ _close(fp);
+--- file_io.c
++++ file_io.c 2003-10-12 02:24:46.000000000 +0000
+@@ -32,7 +32,7 @@
+ fp = _open(name, _O_BINARY | _O_RDONLY); // check size
+ if (fp != -1)
+ {
+- __int64 fposition = _filelengthi64(fp);
++ __int64_t fposition = lseek64(fp, 0, SEEK_END);
+
+ f->written_to = fposition > 0;
+ if (fposition > 0)
diff --git a/media-video/vstrip/metadata.xml b/media-video/vstrip/metadata.xml
new file mode 100644
index 000000000000..58cae4f48bf3
--- /dev/null
+++ b/media-video/vstrip/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+A program to divide a non encrypted vob by individiual chapters
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
new file mode 100644
index 000000000000..ecea22d429b2
--- /dev/null
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A program to split non-css dvd vobs into individual chapters"
+HOMEPAGE="http://www.maven.de/code"
+SRC_URI="http://files.digital-digest.com/downloads/files/encode/vStrip_${PV/./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix *.c *.h
+
+ for file in *.c *.h ; do
+ echo >>$file
+ done
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin vstrip
+}