summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-14 21:53:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-14 22:32:06 +0200
commit50aec3043faff52705e197a804a5ef266ac03618 (patch)
tree1404e6b3c4c9071a1318a41b21cb938a6c3ccd8a /media-video/transcode
parentkde-apps/filelight: fix build and running on musl (diff)
downloadgentoo-50aec3043faff52705e197a804a5ef266ac03618.tar.gz
gentoo-50aec3043faff52705e197a804a5ef266ac03618.tar.bz2
gentoo-50aec3043faff52705e197a804a5ef266ac03618.zip
media-video/transcode: EAPI-8 bump, HOMEPAGE dead, minor style fixes
Both - http://www.transcoding.org/ - https://bitbucket.org/france/transcode-tcforge ...are dead. Closes: https://bugs.gentoo.org/739800 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/transcode')
-rw-r--r--media-video/transcode/transcode-1.1.7-r6.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/media-video/transcode/transcode-1.1.7-r6.ebuild b/media-video/transcode/transcode-1.1.7-r6.ebuild
index 27b8a8cfff4b..2c446a83b2d3 100644
--- a/media-video/transcode/transcode-1.1.7-r6.ebuild
+++ b/media-video/transcode/transcode-1.1.7-r6.ebuild
@@ -1,11 +1,12 @@
# Copyright 2002-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools
DESCRIPTION="Utilities for transcoding video and audio codecs in different containers"
-HOMEPAGE="http://www.transcoding.org/ https://bitbucket.org/france/transcode-tcforge"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="https://www.bitbucket.org/france/${PN}-tcforge/downloads/${P}.tar.bz2
https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2
https://dev.gentoo.org/~whissi/dist/${PN}/${PN}-1.1.7-ffmpeg4.patch.xz"
@@ -15,6 +16,13 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm64 ppc ppc64 ~riscv sparc x86"
IUSE="cpu_flags_x86_3dnow a52 aac alsa altivec dv dvd +iconv imagemagick jpeg lzo mjpeg cpu_flags_x86_mmx mp3 mpeg nuv ogg oss pic postproc quicktime sdl cpu_flags_x86_sse cpu_flags_x86_sse2 theora truetype v4l vorbis X x264 xml xvid"
+REQUIRED_USE="
+ cpu_flags_x86_sse? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx cpu_flags_x86_sse )
+ cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )
+ nuv? ( lzo )
+"
+
RDEPEND="
>=media-video/ffmpeg-0.10
a52? ( media-libs/a52dec )
@@ -37,25 +45,21 @@ RDEPEND="
truetype? ( >=media-libs/freetype-2 )
v4l? ( media-libs/libv4l )
vorbis? ( media-libs/libvorbis )
- X? ( x11-libs/libXpm x11-libs/libXaw x11-libs/libXv )
+ X? (
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/libXv
+ )
x264? ( media-libs/x264:= )
xml? ( dev-libs/libxml2 )
xvid? ( media-libs/xvid )
- "
-
+"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
v4l? ( >=sys-kernel/linux-headers-2.6.11 )
"
-REQUIRED_USE="
- cpu_flags_x86_sse? ( cpu_flags_x86_mmx )
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx cpu_flags_x86_sse )
- cpu_flags_x86_3dnow? ( cpu_flags_x86_mmx )
- nuv? ( lzo )
- "
-
PATCHES=(
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg.patch
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg-0.10.patch
@@ -67,7 +71,7 @@ PATCHES=(
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg2.patch
"${WORKDIR}"/${P}-patchset/${P}-freetype251.patch
"${WORKDIR}"/${P}-patchset/${P}-ffmpeg24.patch
- "${FILESDIR}"/${P}-swresample.patch #722296
+ "${FILESDIR}"/${P}-swresample.patch # bug 722296
"${FILESDIR}"/${P}-gcc10-fno-common.patch
"${FILESDIR}"/${P}-glibc-2.32.patch
)
@@ -82,7 +86,7 @@ src_prepare() {
fi
if has_version '>=media-video/ffmpeg-4' ; then
- PATCHES+=( "${WORKDIR}/transcode-1.1.7-ffmpeg4.patch" )
+ PATCHES+=( "${WORKDIR}"/${P}-ffmpeg4.patch )
fi
default
@@ -92,7 +96,7 @@ src_prepare() {
src_configure() {
local myconf
- use x86 && myconf="$(use_enable !pic x86-textrels)" #271476
+ use x86 && myconf="$(use_enable !pic x86-textrels)" # bug 271476
local myeconfargs=(
$(use_enable cpu_flags_x86_mmx mmx)