summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2024-08-23 17:28:42 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-30 11:11:54 +0300
commitec6bb254527d24ecb3aa02272230caa470e7efb7 (patch)
tree958be19bffde575afac796cf4b47ae92ef8344e4 /media-video/shotcut
parentmedia-video/shotcut: drop 23.09.29 (diff)
downloadgentoo-ec6bb254527d24ecb3aa02272230caa470e7efb7.tar.gz
gentoo-ec6bb254527d24ecb3aa02272230caa470e7efb7.tar.bz2
gentoo-ec6bb254527d24ecb3aa02272230caa470e7efb7.zip
media-video/shotcut: add 24.06.26
Closes: https://bugs.gentoo.org/938257 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/38261 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/shotcut-24.06.26.ebuild53
-rw-r--r--media-video/shotcut/shotcut-9999.ebuild6
3 files changed, 58 insertions, 2 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index aeeb658de7dd..6b436d457909 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1 +1,2 @@
DIST shotcut-24.02.19.tar.gz 12077171 BLAKE2B ac7ab500f8817007ec981a94a2b7a414a4d981c630bd289fdf70eb2f1d493391dc74e372d82273aa4d81a2a9b685b1275e30ab47f6d6c5ce44812c286f43ed54 SHA512 60fc8874622db7ebb3e345ac8ba23a0d7c5e60c929c5955189b71540bbd5946e4dc0db0ad119a4ba3659f2d6e4dd64652be3dabc82b3c01feefb5619685ec454
+DIST shotcut-24.06.26.tar.gz 12276595 BLAKE2B 0f062f3cb3991291b962fd351cac266bf20fd7d58acb70245655b93cbdbc7147a24e17d4ecf4eaa1bd5e3bbf29a29b73f289d529c539f6540616e3a03bf82ac5 SHA512 282c3f73cedae9b1fcb85d08a18fcd164481307baaca0227f536846ee0fc1c2f09382d0ba40fb0993210c78e7192338fa3577fe9c963e8bfc5a9d5bacc912a8b
diff --git a/media-video/shotcut/shotcut-24.06.26.ebuild b/media-video/shotcut/shotcut-24.06.26.ebuild
new file mode 100644
index 000000000000..b72aafd2d6c0
--- /dev/null
+++ b/media-video/shotcut/shotcut-24.06.26.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+IUSE="debug"
+
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+"
+DEPEND="
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,widgets,xml]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtcharts:6
+ >=media-libs/mlt-7.18.0[ffmpeg,frei0r,jack,opengl,sdl,xml]
+ media-video/ffmpeg
+"
+
+RDEPEND="${DEPEND}
+ virtual/jack
+"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+ if [[ ${PV} != 9999* ]] ; then
+ SHOTCUT_VERSION="${PV}"
+ else
+ SHOTCUT_VERSION="$(git log --date=format:'%y.%m.%d' -1 --format='%ad')"
+ fi
+ local mycmakeargs=(
+ -DSHOTCUT_VERSION="${SHOTCUT_VERSION}"
+ )
+ use debug || append-cxxflags "-DNDEBUG"
+ append-cxxflags "-DSHOTCUT_NOUPGRADE"
+ cmake_src_configure
+}
diff --git a/media-video/shotcut/shotcut-9999.ebuild b/media-video/shotcut/shotcut-9999.ebuild
index 88276adaf800..b72aafd2d6c0 100644
--- a/media-video/shotcut/shotcut-9999.ebuild
+++ b/media-video/shotcut/shotcut-9999.ebuild
@@ -15,11 +15,12 @@ else
EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
fi
-IUSE="debug"
-
LICENSE="GPL-3+"
+
SLOT="0"
+IUSE="debug"
+
BDEPEND="
dev-qt/qttools:6[linguist]
"
@@ -27,6 +28,7 @@ DEPEND="
dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,widgets,xml]
dev-qt/qtdeclarative:6[widgets]
dev-qt/qtmultimedia:6
+ dev-qt/qtcharts:6
>=media-libs/mlt-7.18.0[ffmpeg,frei0r,jack,opengl,sdl,xml]
media-video/ffmpeg
"