summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-15 14:43:07 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-16 16:58:01 +0800
commitf64a99bc60bdb101d4ef9c2f9ab6fdc7cd842637 (patch)
treee769053bfcb9b6d010b1d1783b46526e55f09673 /media-video/openshot
parentdev-libs/cyberjack: version bump. upstream removed /usr/bin/fxcyberjack and /... (diff)
downloadgentoo-f64a99bc60bdb101d4ef9c2f9ab6fdc7cd842637.tar.gz
gentoo-f64a99bc60bdb101d4ef9c2f9ab6fdc7cd842637.tar.bz2
gentoo-f64a99bc60bdb101d4ef9c2f9ab6fdc7cd842637.zip
media-video/openshot: bump to 2.0.6, add myself as proxied maintainer
Use a new slot as this version is completely different from the old 1.4 releases and both may be installed at the same time. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=575344 Package-Manager: portage-2.2.27 Closes: https://github.com/gentoo/gentoo/pull/1057
Diffstat (limited to 'media-video/openshot')
-rw-r--r--media-video/openshot/Manifest1
-rw-r--r--media-video/openshot/metadata.xml13
-rw-r--r--media-video/openshot/openshot-2.0.6.ebuild54
3 files changed, 67 insertions, 1 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
index 2e4ed368b26e..c84267d2a182 100644
--- a/media-video/openshot/Manifest
+++ b/media-video/openshot/Manifest
@@ -1 +1,2 @@
DIST openshot-1.4.3.tar.gz 31990991 SHA256 5bebf1c59a8667b0263599544f2d23ce6be3ab79ce24a85b766e1e39cab859d0 SHA512 f3221c3e508ccf61d4fd2771de47f42ddb1a78996853011ee336e8ccf842a0fd97707a60c677e1465a89e6eb67911b6eb98b002959f8a29ac9e31924bbb6fcda WHIRLPOOL 4fd8d5b5db2923c8b7349032847087b9cf4ccdbade206c5c6cc9aac27ace6e99c6053bd1184cf14b20c80b4f666baf356798a5b6a8d6c7c737a9a986894943af
+DIST openshot-qt-2.0.6.tar.gz 91612365 SHA256 80a7ad0fa5e2f4fc8bcccc1c2c8c4a6d73315b63f8263a0c374c2ffd4faa6c5c SHA512 cec7ece06d7ceb69440e413b372fb3c40bab36391f19acfd94c42ae9b0ccab7bee2dc2b335febf0f2a61788991aea34f72c07df7a5eaacab8bcd9f0de315114b WHIRLPOOL 10270675cbd783b21e446bd5cbe3712fa12dc1d28e66772fde60ed4e155524d1b297e1c6267bc4190b47445252fb9a4d11ab60fa697106eea6ad08fe4fb599f6
diff --git a/media-video/openshot/metadata.xml b/media-video/openshot/metadata.xml
index 4e5719349b44..48b78f8eeab7 100644
--- a/media-video/openshot/metadata.xml
+++ b/media-video/openshot/metadata.xml
@@ -1,9 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>Free, open-source, non-linear video editor to create and edit videos and movies</longdescription>
<upstream>
<remote-id type="launchpad">openshot</remote-id>
+ <remote-id type="github">OpenShot/openshot-qt</remote-id>
+ <bugs-to>https://github.com/OpenShot/openshot-qt/issues</bugs-to>
+ <bugs-to>https://bugs.launchpad.net/openshot/+bugs</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/media-video/openshot/openshot-2.0.6.ebuild b/media-video/openshot/openshot-2.0.6.ebuild
new file mode 100644
index 000000000000..fa568a1281b6
--- /dev/null
+++ b/media-video/openshot/openshot-2.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_REQ_USE=xml
+PYTHON_COMPAT=( python3_{4,5} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit versionator distutils-r1 gnome2-utils xdg
+
+MY_PN="${PN}-qt"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Free, open-source, non-linear video editor to create and edit videos and movies"
+HOMEPAGE="http://www.openshot.org/ https://launchpad.net/libopenshot"
+SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/PyQt5[webkit,${PYTHON_USEDEP}]
+ media-libs/libopenshot[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # prevent setup.py from trying to update MIME databases
+ sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+ xdg_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}