summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-13 12:43:49 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-13 12:43:49 +0100
commitfc5fbdd7dec72404c1e92642fe561eceb787fc1c (patch)
treeedb4f392d12b87fef1d8589fbd4f6fba071a3e9b /media-video/mpv
parentmedia-video/ffmpeg: USE=video_cards_nvidia → nvenc (diff)
downloadgentoo-fc5fbdd7dec72404c1e92642fe561eceb787fc1c.tar.gz
gentoo-fc5fbdd7dec72404c1e92642fe561eceb787fc1c.tar.bz2
gentoo-fc5fbdd7dec72404c1e92642fe561eceb787fc1c.zip
media-video/mpv: USE=cuda → nvenc
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/metadata.xml1
-rw-r--r--media-video/mpv/mpv-0.33.1-r2.ebuild16
-rw-r--r--media-video/mpv/mpv-0.34.0.ebuild16
-rw-r--r--media-video/mpv/mpv-9999.ebuild16
4 files changed, 24 insertions, 25 deletions
diff --git a/media-video/mpv/metadata.xml b/media-video/mpv/metadata.xml
index 976440320d4f..8f8efa409921 100644
--- a/media-video/mpv/metadata.xml
+++ b/media-video/mpv/metadata.xml
@@ -10,7 +10,6 @@
<flag name="bluray">Enable playback of Blu-ray filesystems</flag>
<flag name="cli">Build mpv CLI player</flag>
<flag name="cplugins">Enable C plugins support</flag>
- <flag name="cuda">Enable hardware video decoding via Nvidia CUDA</flag>
<flag name="drm">Enable Kernel Mode Setting / Direct Rendering Manager based video output</flag>
<flag name="egl">Enable support for various EGL-based video outputs / backends</flag>
<flag name="gamepad">Enable gamepad input support</flag>
diff --git a/media-video/mpv/mpv-0.33.1-r2.ebuild b/media-video/mpv/mpv-0.33.1-r2.ebuild
index 6dc6afe6bc87..69fc1d6faa71 100644
--- a/media-video/mpv/mpv-0.33.1-r2.ebuild
+++ b/media-video/mpv/mpv-0.33.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,20 +29,20 @@ DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda debug doc drm dvb
+IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins debug doc drm dvb
dvd +egl gamepad gbm +iconv jack javascript jpeg lcms libcaca libmpv +lua
- openal +opengl pulseaudio raspberry-pi rubberband sdl
+ nvenc openal +opengl pulseaudio raspberry-pi rubberband sdl
selinux test tools +uchardet vaapi vdpau vulkan wayland +X +xv zlib zimg"
REQUIRED_USE="
|| ( cli libmpv )
aqua? ( opengl )
- cuda? ( opengl )
egl? ( || ( gbm X wayland ) )
gamepad? ( sdl )
gbm? ( drm egl opengl )
lcms? ( opengl )
lua? ( ${LUA_REQUIRED_USE} )
+ nvenc? ( opengl )
opengl? ( || ( aqua egl X raspberry-pi !cli ) )
raspberry-pi? ( opengl )
test? ( opengl )
@@ -118,11 +118,11 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
- cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
dvb? ( virtual/linuxtv-dvb-headers )
+ nvenc? ( >=media-libs/nv-codec-headers-8.2.15.7 )
"
RDEPEND="${COMMON_DEPEND}
- cuda? ( x11-drivers/nvidia-drivers[X] )
+ nvenc? ( x11-drivers/nvidia-drivers[X] )
selinux? ( sec-policy/selinux-mplayer )
tools? ( ${PYTHON_DEPS} )
"
@@ -224,8 +224,8 @@ src_configure() {
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
- $(use_enable cuda cuda-hwaccel)
- $(use_enable cuda cuda-interop)
+ $(use_enable nvenc cuda-hwaccel)
+ $(use_enable nvenc cuda-interop)
# TV features:
$(use_enable dvb dvbin)
diff --git a/media-video/mpv/mpv-0.34.0.ebuild b/media-video/mpv/mpv-0.34.0.ebuild
index dd43d1178adb..e0f0ee5c96cf 100644
--- a/media-video/mpv/mpv-0.34.0.ebuild
+++ b/media-video/mpv/mpv-0.34.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,20 +29,20 @@ DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda debug doc drm dvb
+IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins debug doc drm dvb
dvd +egl gamepad gbm +iconv jack javascript jpeg lcms libcaca libmpv +lua
- openal +opengl pulseaudio raspberry-pi rubberband sdl
+ nvenc openal +opengl pulseaudio raspberry-pi rubberband sdl
selinux test tools +uchardet vaapi vdpau vulkan wayland +X +xv zlib zimg"
REQUIRED_USE="
|| ( cli libmpv )
aqua? ( opengl )
- cuda? ( opengl )
egl? ( || ( gbm X wayland ) )
gamepad? ( sdl )
gbm? ( drm egl opengl )
lcms? ( opengl )
lua? ( ${LUA_REQUIRED_USE} )
+ nvenc? ( opengl )
opengl? ( || ( aqua egl X raspberry-pi !cli ) )
raspberry-pi? ( opengl )
test? ( opengl )
@@ -118,11 +118,11 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
- cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
dvb? ( virtual/linuxtv-dvb-headers )
+ nvenc? ( >=media-libs/nv-codec-headers-8.2.15.7 )
"
RDEPEND="${COMMON_DEPEND}
- cuda? ( x11-drivers/nvidia-drivers[X] )
+ nvenc? ( x11-drivers/nvidia-drivers[X] )
selinux? ( sec-policy/selinux-mplayer )
tools? ( ${PYTHON_DEPS} )
"
@@ -224,8 +224,8 @@ src_configure() {
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
- $(use_enable cuda cuda-hwaccel)
- $(use_enable cuda cuda-interop)
+ $(use_enable nvenc cuda-hwaccel)
+ $(use_enable nvenc cuda-interop)
# TV features:
$(use_enable dvb dvbin)
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index dd43d1178adb..e0f0ee5c96cf 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,20 +29,20 @@ DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda debug doc drm dvb
+IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins debug doc drm dvb
dvd +egl gamepad gbm +iconv jack javascript jpeg lcms libcaca libmpv +lua
- openal +opengl pulseaudio raspberry-pi rubberband sdl
+ nvenc openal +opengl pulseaudio raspberry-pi rubberband sdl
selinux test tools +uchardet vaapi vdpau vulkan wayland +X +xv zlib zimg"
REQUIRED_USE="
|| ( cli libmpv )
aqua? ( opengl )
- cuda? ( opengl )
egl? ( || ( gbm X wayland ) )
gamepad? ( sdl )
gbm? ( drm egl opengl )
lcms? ( opengl )
lua? ( ${LUA_REQUIRED_USE} )
+ nvenc? ( opengl )
opengl? ( || ( aqua egl X raspberry-pi !cli ) )
raspberry-pi? ( opengl )
test? ( opengl )
@@ -118,11 +118,11 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
- cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
dvb? ( virtual/linuxtv-dvb-headers )
+ nvenc? ( >=media-libs/nv-codec-headers-8.2.15.7 )
"
RDEPEND="${COMMON_DEPEND}
- cuda? ( x11-drivers/nvidia-drivers[X] )
+ nvenc? ( x11-drivers/nvidia-drivers[X] )
selinux? ( sec-policy/selinux-mplayer )
tools? ( ${PYTHON_DEPS} )
"
@@ -224,8 +224,8 @@ src_configure() {
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
- $(use_enable cuda cuda-hwaccel)
- $(use_enable cuda cuda-interop)
+ $(use_enable nvenc cuda-hwaccel)
+ $(use_enable nvenc cuda-interop)
# TV features:
$(use_enable dvb dvbin)