summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild')
-rw-r--r--media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild b/media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild
new file mode 100644
index 000000000000..5deefec95577
--- /dev/null
+++ b/media-video/mkvtoolnix/mkvtoolnix-6.6.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs versionator wxwidgets multiprocessing autotools
+
+DESCRIPTION="Tools to create, alter, and inspect Matroska files"
+HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug pch qt4 wxwidgets"
+
+RDEPEND="
+ >=dev-libs/libebml-1.3.0:=
+ >=media-libs/libmatroska-1.4.1:=
+ >=dev-libs/boost-1.46.0:=
+ dev-libs/pugixml
+ media-libs/flac
+ media-libs/libogg
+ media-libs/libvorbis
+ sys-apps/file
+ >=sys-devel/gcc-4.6
+ sys-libs/zlib
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )
+"
+DEPEND="${RDEPEND}
+ dev-lang/ruby
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ # http://bugs.gentoo.org/419257
+ local ver=4.6
+ local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+ if ! version_is_at_least ${ver} $(gcc-version); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.8.0-system-pugixml.patch \
+ "${FILESDIR}"/${PN}-5.8.0-boost-configure.patch \
+ "${FILESDIR}"/${PN}-6.6.0-boost-1.56.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use wxwidgets ; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ myconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable qt4 qt) \
+ $(use_enable wxwidgets) \
+ $(usex pch "" --disable-precompiled-headers) \
+ ${myconf} \
+ --disable-optimization \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-boost="${EPREFIX}"/usr \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --without-curl
+}
+
+src_compile() {
+ ./drake V=1 -j$(makeopts_jobs) || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./drake -j$(makeopts_jobs) install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+ doman doc/man/*.1
+
+ use wxwidgets && docompress -x /usr/share/doc/${PF}/guide
+}