summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-19 16:51:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-19 18:40:59 +0200
commit655e4810e32870dbcc50b2e11f300fdc49ea5d30 (patch)
treef0a5aa5682fa80f839e9baa72d7dbce7216d52bd /media-video/ffmpeg
parentmedia-video/ffmpeg: add libaribb24 useflag (diff)
downloadgentoo-655e4810e32870dbcc50b2e11f300fdc49ea5d30.tar.gz
gentoo-655e4810e32870dbcc50b2e11f300fdc49ea5d30.tar.bz2
gentoo-655e4810e32870dbcc50b2e11f300fdc49ea5d30.zip
media-video/ffmpeg: add cuda useflag.
Based on a patch by Timo Rothenpieler. Closes: https://bugs.gentoo.org/595450 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 75bc08762ecb..ac797b13647f 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -80,7 +80,7 @@ FFMPEG_FLAG_MAP=(
vorbis:libvorbis vpx:libvpx zvbi:libzvbi
# libavfilter options
appkit
- bs2b:libbs2b chromaprint flite:libflite frei0r
+ bs2b:libbs2b chromaprint cuda:cuda-llvm flite:libflite frei0r
fribidi:libfribidi fontconfig ladspa libass lv2 truetype:libfreetype vidstab:libvidstab
rubberband:librubberband zeromq:libzmq zimg:libzimg
# libswresample options
@@ -278,9 +278,10 @@ DEPEND="${RDEPEND}
"
BDEPEND="
>=sys-devel/make-3.81
- doc? ( sys-apps/texinfo )
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
cpu_flags_x86_mmx? ( || ( >=dev-lang/nasm-2.13 >=dev-lang/yasm-1.3 ) )
+ cuda? ( >=sys-devel/clang-7[llvm_targets_NVPTX] )
+ doc? ( sys-apps/texinfo )
test? ( net-misc/wget sys-devel/bc )
"
@@ -298,6 +299,7 @@ GPL_REQUIRED_USE="
)
"
REQUIRED_USE="
+ cuda? ( video_cards_nvidia )
libv4l? ( v4l )
fftools_cws2fws? ( zlib )
test? ( encode )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 556156808d6f..fbc47af1d136 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -19,6 +19,7 @@
<flag name="chromium">Builds libffmpeg.so to enable media playback in Chromium-based browsers like Opera and Vivaldi.</flag>
<flag name="codec2">Enables codec2 low bit rate speech codec support via <pkg>media-libs/codec2</pkg>.</flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
+ <flag name="cuda">Enables CUDA-based acceleration. Mostly used for specific filters.</flag>
<flag name="dav1d">Enables AV1 decoding via<pkg>media-libs/dav1d</pkg>.</flag>
<flag name="ebur128">Enables EBU R128 loudness normalization filter via <pkg>media-libs/libebur128</pkg></flag>
<flag name="fdk">Use external fdk-aac library for AAC encoding</flag>