summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-30 09:59:02 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-30 10:13:14 +0200
commit584dfbbe855193e26e5e5cf4cd1e94605a4913e4 (patch)
treec36017b29361661ea3d46e0baab7b52c5dfb4343 /media-video/droidcam
parentgames-emulation/dolphin: add IUSE=mgba (diff)
downloadgentoo-584dfbbe855193e26e5e5cf4cd1e94605a4913e4.tar.gz
gentoo-584dfbbe855193e26e5e5cf4cd1e94605a4913e4.tar.bz2
gentoo-584dfbbe855193e26e5e5cf4cd1e94605a4913e4.zip
media-video/droidcam: add version 1.8.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video/droidcam')
-rw-r--r--media-video/droidcam/Manifest1
-rw-r--r--media-video/droidcam/droidcam-1.8.0.ebuild144
-rw-r--r--media-video/droidcam/files/droidcam-makefile-fixes.patch12
3 files changed, 151 insertions, 6 deletions
diff --git a/media-video/droidcam/Manifest b/media-video/droidcam/Manifest
index 9d21ae1f8136..6a9b200974b9 100644
--- a/media-video/droidcam/Manifest
+++ b/media-video/droidcam/Manifest
@@ -1 +1,2 @@
DIST droidcam-1.7.3.tar.gz 83146 BLAKE2B b79d210a7d6a3cee7322b373cd92b2c1a326dd9887dff1df752e9818f9e7ed88dfdfd4a33a22ccb39c601df81c4e9538b1efa8029a9ad56f39d400fc50bc746b SHA512 39d6947b66f1be7896c56aa01d471cbd025deaeb2d2359f9434e5ea91e4302f4c16ee31486bb04fab1dfc7f6d8b2de3f6800ead665b7b3d366b01b25297beaba
+DIST droidcam-1.8.0.tar.gz 84376 BLAKE2B 581e57e2c80dd9662764e399dd797e5893f617e69ee2501a1063d1c51434baf64d7d2b72779debede6d679127f31fa95a4e67953978da591acbf6a41bd05551d SHA512 b448f686562030b352630c6b677a098ecb5041582dd06e57809b04674cb334d02ddfdf1d09b43e1ecc70897e8073714ad6913ab14d894a7679fc433adb3fda82
diff --git a/media-video/droidcam/droidcam-1.8.0.ebuild b/media-video/droidcam/droidcam-1.8.0.ebuild
new file mode 100644
index 000000000000..60f47eb1847b
--- /dev/null
+++ b/media-video/droidcam/droidcam-1.8.0.ebuild
@@ -0,0 +1,144 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop linux-mod xdg
+
+DESCRIPTION="Use your phone or tablet as webcam with a v4l device driver and app"
+HOMEPAGE="https://www.dev47apps.com/droidcam/linux/"
+SRC_URI="https://github.com/dev47apps/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="gtk"
+
+# Requires connection to phone/tablet
+RESTRICT="test"
+
+DEPEND="
+ app-pda/libplist
+ app-pda/libusbmuxd
+ dev-libs/glib
+ dev-libs/libappindicator:3
+ dev-libs/libxml2
+ dev-util/android-tools
+ media-libs/alsa-lib
+ media-libs/libjpeg-turbo
+ >=media-libs/speex-1.2.0-r1
+ media-video/ffmpeg
+ gtk? (
+ dev-cpp/gtkmm:3.0
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="v4l2loopback-dc(video:${S}/v4l2loopback:${S}/v4l2loopback)"
+MODULESD_V4L2LOOPBACK_DC_ENABLED="yes"
+
+CONFIG_CHECK="~SND_ALOOP VIDEO_DEV MEDIA_SUPPORT MEDIA_CAMERA_SUPPORT"
+ERROR_SND_ALOOP="CONFIG_SND_ALOOP is optionally required for audio support"
+
+PATCHES="${FILESDIR}/${PN}-makefile-fixes.patch"
+
+src_prepare() {
+ if ! use gtk; then
+ sed -i -e '/cflags gtk+/d' Makefile || die
+ default
+ else
+ # remove path and extension from Icon and Exec entry
+ sed -i -e 's/Icon=\/opt\/droidcam-icon.png/Icon=droidcam/g' \
+ -e 's/\/usr\/local\/bin\/droidcam/droidcam/g' \
+ droidcam.desktop || die
+ sed -i -e 's%/opt/droidcam-icon.png%/usr/share/icons/hicolor/96x96/apps/droidcam.png%g' src/droidcam.c || die
+ xdg_src_prepare
+ fi
+}
+
+src_configure() {
+ set_arch_to_kernel
+ default
+}
+
+src_compile() {
+ if use gtk; then
+ emake droidcam
+ fi
+ emake droidcam-cli
+ KERNELRELEASE="${KV_FULL}" linux-mod_src_compile
+}
+
+src_test() {
+ pushd "v4l2loopback" || die
+ default
+ ./test || die
+ popd || die
+}
+
+src_install() {
+ if use gtk; then
+ dobin droidcam
+ newicon -s 32 icon.png droidcam.png
+ newicon -s 96 icon2.png droidcam.png
+ domenu droidcam.desktop
+ fi
+ dobin droidcam-cli
+
+ # The cli and gui do not auto load the module if unloaded (why not though?)
+ # so we just put it in modules-load.d to make sure it always works
+ insinto /etc/modules-load.d
+ if linux_config_exists; then
+ if linux_chkconfig_module SND_ALOOP; then
+ newins - "${PN}.conf" <<-EOF
+ v4l2loopback-dc
+ snd_aloop
+ EOF
+ else
+ newins - "${PN}.conf" <<-EOF
+ v4l2loopback-dc
+ EOF
+ fi
+ fi
+
+ einstalldocs
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ if use gtk; then
+ xdg_pkg_preinst
+ fi
+ linux-mod_pkg_preinst
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ if use gtk; then
+ xdg_pkg_postinst
+ else
+ elog
+ elog "Only droidcam-cli has been installed since 'gtk' flag was not set"
+ elog
+ fi
+
+ elog "The default resolution for v4l2loopback-dc (i.e. droidcam) is 640x480."
+ elog "You can change this value in /etc/modprobe.d/v4l2loopback-dc.conf"
+ elog
+ elog "Links to the Android/iPhone/iPad apps can be found at"
+ elog "https://www.dev47apps.com/"
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_pkg_postrm
+ fi
+ linux-mod_pkg_postrm
+}
diff --git a/media-video/droidcam/files/droidcam-makefile-fixes.patch b/media-video/droidcam/files/droidcam-makefile-fixes.patch
index c413d7edd11c..5230c18f0f33 100644
--- a/media-video/droidcam/files/droidcam-makefile-fixes.patch
+++ b/media-video/droidcam/files/droidcam-makefile-fixes.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index b5f696c..bcb5800 100644
+index 7be3c15..099a707 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@
@@ -17,7 +17,7 @@ index b5f696c..bcb5800 100644
LIBS = -lspeex -lasound -lpthread -lm
-JPEG = -I$(JPEG_INCLUDE) $(JPEG_LIB)/libturbojpeg.a
+JPEG = -I$(JPEG_INCLUDE) $(JPEG_LIB)/libturbojpeg.so
- SRC = src/connection.c src/settings.c src/decoder*.c src/av.c src/usb.c
+ SRC = src/connection.c src/settings.c src/decoder*.c src/av.c src/usb.c src/queue.c
-USBMUXD = -lusbmuxd
+USBMUXD = -lusbmuxd-2.0
@@ -35,13 +35,13 @@ index b5f696c..bcb5800 100644
droidcam-cli: LDLIBS += $(JPEG) $(LIBAV) $(LIBS)
droidcam-cli: src/droidcam-cli.c $(SRC)
-- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
+- $(CC) $(CPPFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
++ $(CC) $(CPPFLAGS) $(CXXFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
droidcam: LDLIBS += $(GTK) $(JPEG) $(LIBAV) $(LIBS)
droidcam: src/droidcam.c src/resources.c $(SRC)
-- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
+- $(CC) $(CPPFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
++ $(CC) $(CPPFLAGS) $(CXXFLAGS) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(LDLIBS)
clean:
rm -f droidcam