summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-29 00:51:20 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-29 01:06:21 +0300
commit7e2eb99fb1941a72a2779b954c2c71feb87af107 (patch)
treea9a56ec8f5179e1dbdd8ce009bd234ccdf3528aa /media-video/avidemux
parentdev-python/aiohttp: Remove old versions (diff)
downloadgentoo-7e2eb99fb1941a72a2779b954c2c71feb87af107.tar.gz
gentoo-7e2eb99fb1941a72a2779b954c2c71feb87af107.tar.bz2
gentoo-7e2eb99fb1941a72a2779b954c2c71feb87af107.zip
media-video/avidemux: fix .desktop file
Reported-by: Toralf Förster <toralf@gentoo.org> Reported-by: Bernd Feige <bernd.feige@gmx.net> Closes: https://bugs.gentoo.org/692898 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/avidemux-2.7.4-r1.ebuild (renamed from media-video/avidemux/avidemux-2.7.4.ebuild)36
1 files changed, 18 insertions, 18 deletions
diff --git a/media-video/avidemux/avidemux-2.7.4.ebuild b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
index 8e047a6a29cc..8bf214ecf0b3 100644
--- a/media-video/avidemux/avidemux-2.7.4.ebuild
+++ b/media-video/avidemux/avidemux-2.7.4-r1.ebuild
@@ -49,23 +49,22 @@ src_prepare() {
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
done
- # Fix icon name -> avidemux-2.7
- sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/${PN}.desktop || \
- die "Icon name fix failed."
+ if use qt5; then
+ # Fix icon name -> avidemux-2.7
+ sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/${PN}.desktop || \
+ die "Icon name fix failed."
- # The desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.7 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" appImage/${PN}.desktop || \
- die "Desktop file fix failed."
- use qt5 && sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt5:' appImage/${PN}.desktop || \
- die "Desktop file fix failed."
+ # The desktop file is broken. It uses avidemux3_portable instead of avidemux3_qt5
+ sed -i -re '/^Exec/ s:(avidemux3_)portable:\1qt5:' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
- # QA warnings: missing trailing ';' and 'Application' is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/${PN}.desktop || \
- die "Desktop file fix failed."
+ # QA warnings: missing trailing ';' and 'Application' is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/${PN}.desktop || \
+ die "Desktop file fix failed."
- # Now rename the desktop file to not collide with 2.6.
- mv appImage/${PN}.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
+ # Now rename the desktop file to not collide with 2.6.
+ mv appImage/${PN}.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
+ fi
# Remove "Build Option" dialog because it doesn't reflect
# what the GUI can or has been built with. (Bug #463628)
@@ -122,8 +121,9 @@ src_install() {
BUILD_DIR="${build}" cmake-utils_src_install
done
- cd "${S}" || die "Can't enter source folder"
- newicon ${PN}_icon.png ${PN}-${SLOT}.png
-
- use qt5 && domenu ${PN}-${SLOT}.desktop
+ if use qt5; then
+ cd "${S}" || die "Can't enter source folder"
+ newicon ${PN}_icon.png ${PN}-${SLOT}.png
+ domenu ${PN}-${SLOT}.desktop
+ fi
}