summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/asfrecorder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/asfrecorder')
-rw-r--r--media-video/asfrecorder/Manifest1
-rw-r--r--media-video/asfrecorder/asfrecorder-1.1.ebuild34
-rw-r--r--media-video/asfrecorder/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/media-video/asfrecorder/Manifest b/media-video/asfrecorder/Manifest
new file mode 100644
index 000000000000..0882137617d1
--- /dev/null
+++ b/media-video/asfrecorder/Manifest
@@ -0,0 +1 @@
+DIST ASFRecorder.zip 377571 SHA256 fd94d102231a31a56c368e02a30e6e700573a0f145c8be48173843b7e9054ea8
diff --git a/media-video/asfrecorder/asfrecorder-1.1.ebuild b/media-video/asfrecorder/asfrecorder-1.1.ebuild
new file mode 100644
index 000000000000..360b89764c7d
--- /dev/null
+++ b/media-video/asfrecorder/asfrecorder-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_PN="${PN/asfr/ASFR}"
+DESCRIPTION="ASFRecorder - Download Windows Media Streaming files"
+HOMEPAGE="http://sourceforge.net/projects/asfrecorder/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ # There is a Makefile, but it only works for Cygwin, so we
+ # only compile this single program.
+ cd "${S}"/source
+ $(tc-getCC) -o asfrecorder ${CFLAGS} ${LDFLAGS} asfrecorder.c || die "Build failed"
+}
+
+src_install () {
+ # Again, no makefiles, so just take what we want.
+ dobin source/asfrecorder
+ dodoc README.TXT
+}
diff --git a/media-video/asfrecorder/metadata.xml b/media-video/asfrecorder/metadata.xml
new file mode 100644
index 000000000000..ef1903383336
--- /dev/null
+++ b/media-video/asfrecorder/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">asfrecorder</remote-id>
+ </upstream>
+</pkgmetadata>