summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-12-12 16:55:12 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-12-12 17:22:01 +0000
commit98acc6f89fe4bdfee68ff2f52c4deeb952460bd8 (patch)
treee4d8eca92d681292a5bd913d2524cbf042465615 /media-tv
parentmedia-libs/libv4l: Version bump to 1.26.0 (diff)
downloadgentoo-98acc6f89fe4bdfee68ff2f52c4deeb952460bd8.tar.gz
gentoo-98acc6f89fe4bdfee68ff2f52c4deeb952460bd8.tar.bz2
gentoo-98acc6f89fe4bdfee68ff2f52c4deeb952460bd8.zip
media-tv/ivtv-utils: Revbump to use libv4l[utils] instead of v4l-utils
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv-utils/ivtv-utils-1.4.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-tv/ivtv-utils/ivtv-utils-1.4.1-r1.ebuild b/media-tv/ivtv-utils/ivtv-utils-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..a7df5a2e2c84
--- /dev/null
+++ b/media-tv/ivtv-utils/ivtv-utils-1.4.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="IVTV utilities for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org/"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/$(ver_cut 1-2).x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl"
+
+RDEPEND="
+ media-libs/libv4l[utils(-)]
+ perl? (
+ dev-perl/Video-Frequencies
+ dev-perl/Video-ivtv
+ dev-perl/Config-IniFiles
+ dev-perl/Tk
+ virtual/perl-Getopt-Long
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-gentoo.patch
+ "${FILESDIR}"/${PN}-1.4.1-overflow.patch
+)
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc -r ChangeLog README doc/.
+
+ if use perl; then
+ dobin utils/perl/*.pl
+ dodoc utils/perl/README.ptune
+ fi
+}