summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-01 08:03:52 +0100
committerSam James <sam@gentoo.org>2021-08-01 19:27:40 +0100
commit1bc7bfc2ebacbbe65f8176233d6271af7d02d8cc (patch)
tree04ccacfeecef5b9519d035db0b3bfd87e26168bd /media-tv
parentmedia-sound/qmidiroute: drop obsolete qt5 C++11 workaround (diff)
downloadgentoo-1bc7bfc2ebacbbe65f8176233d6271af7d02d8cc.tar.gz
gentoo-1bc7bfc2ebacbbe65f8176233d6271af7d02d8cc.tar.bz2
gentoo-1bc7bfc2ebacbbe65f8176233d6271af7d02d8cc.zip
media-tv/v4l-utils: use C++14 for now, drop qt5 workaround for C++11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/v4l-utils/v4l-utils-1.20.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
index 6a579d1605e2..71e15ab03e4a 100644
--- a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
+++ b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
@@ -68,14 +68,15 @@ src_prepare() {
}
src_configure() {
+ append-cxxflags -std=c++14
+
if use qt5; then
- append-cxxflags -std=c++11
local qt5_paths=( \
MOC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/moc" \
UIC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/uic" \
RCC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/rcc" \
)
- if use !opengl; then
+ if ! use opengl; then
sed -e 's/Qt5OpenGL/DiSaBlEd/g' -i configure || die
fi
fi