summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/tvmovie2vdr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/tvmovie2vdr')
-rw-r--r--media-tv/tvmovie2vdr/Manifest1
-rw-r--r--media-tv/tvmovie2vdr/metadata.xml10
-rw-r--r--media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild109
3 files changed, 120 insertions, 0 deletions
diff --git a/media-tv/tvmovie2vdr/Manifest b/media-tv/tvmovie2vdr/Manifest
new file mode 100644
index 000000000000..f7f2e5b00ec8
--- /dev/null
+++ b/media-tv/tvmovie2vdr/Manifest
@@ -0,0 +1 @@
+DIST tvmovie2vdr-0.5.13.tar.gz 214932 SHA256 26952547e0c75b278b1cf928c91d2fdf7e895d60f7c429e287be443896cc0b05
diff --git a/media-tv/tvmovie2vdr/metadata.xml b/media-tv/tvmovie2vdr/metadata.xml
new file mode 100644
index 000000000000..b9c00d0c96fd
--- /dev/null
+++ b/media-tv/tvmovie2vdr/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild b/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild
new file mode 100644
index 000000000000..7f8caacbdf8f
--- /dev/null
+++ b/media-tv/tvmovie2vdr/tvmovie2vdr-0.5.13.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+VDR_CONF_DIR="/etc/vdr"
+VDR_VIDEO_DIR="/var/vdr/video"
+
+CONF_DIR="/etc/vdr/tvmovie2vdr"
+VAR_DIR="/var/vdr/tvmovie2vdr"
+SHARE_DIR="/usr/share/${PN}"
+
+DESCRIPTION="load the program guide from tvmovie and others to vdr"
+HOMEPAGE="http://steckrue.be/tvm2vdr/"
+SRC_URI="http://steckrue.be/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.0
+ >=dev-perl/DateManip-5.42a-r1
+ >=virtual/perl-IO-Compress-1.22
+ >=dev-perl/Archive-Zip-1.14
+ >=dev-perl/Text-Iconv-1.4
+ >=dev-perl/libwww-perl-5.69-r2
+ >=dev-perl/HTML-Parser-3.34-r1
+ >=dev-perl/HTML-Scrubber-0.08
+ >=dev-perl/HTML-TableContentParser-0.13
+ >=dev-perl/XML-Simple-DTDReader-0.03
+ >=media-gfx/imagemagick-6.2.2.3
+ dev-perl/DateManip
+ dev-perl/XML-Simple-DTDReader"
+
+src_compile() {
+ # change default downloadpath in config
+ sed -i config/config.pl_dist \
+ -e "s:channelsfile = .*;:channelsfile = \"${VDR_CONF_DIR}/channels.conf\";:" \
+ -e "s:epgfile = .*;:epgfile = \"${VDR_VIDEO_DIR}/epg.data\";:" \
+ -e "s:downloadprefix = .*;:downloadprefix = \"${VAR_DIR}/downloadfiles/\";:" \
+ -e "s:updateprefix = .*;:updateprefix = \"${VAR_DIR}/downloadupdatefiles/\";:" \
+ -e "s:infosaturl=.*;:infosaturl=\"${VAR_DIR}/infosatepg\";:" \
+ -e 's:imagepath = .*;:imagepath = "/var/vdr/epgimages";:'
+
+ # set correct pathes to conf and include files
+ sed -i tvm2vdr tvinfomerk2vdr clearoldtimer \
+ -e 's:push (@INC, "./config");:push (@INC, "'${CONF_DIR}'");:' \
+ -e 's:push (@INC, "./inc");:push (@INC, "'${SHARE_DIR}/inc'");:' \
+ -e "s:contrib/:${SHARE_DIR}/contrib/:"
+}
+
+src_install() {
+ # config files
+ insinto "${CONF_DIR}"
+ local c
+ for c in channels.pl channels_vps_wanted.pl channels_wanted.pl config.pl; do
+ newins "config/${c}_dist" "${c}"
+ done
+
+ # include files - helpers for different providers
+ insinto "${SHARE_DIR}/inc"
+ doins inc/*
+
+ exeinto "${SHARE_DIR}/contrib"
+ doexe ./contrib/*
+ doexe clearoldtimer getinfosat tvm2vdr.sh
+
+ # install main binaries
+ dobin tvinfomerk2vdr
+ dobin tvm2vdr
+
+ # dirs to keep downloaded data in
+ keepdir "${VAR_DIR}/downloadfiles"
+ keepdir "${VAR_DIR}/downloadupdatefiles"
+ keepdir "/var/vdr/epgimages"
+ chown -R vdr:vdr "${D}/${VAR_DIR}" "${D}/var/vdr/epgimages"
+
+ # install documentation
+ dodoc HISTORY README tvm2vdr.sh
+}
+
+pkg_postinst() {
+ # cleanup old cruft
+ [ -L "${ROOT}/etc/vdr/tvmovie2vdr/files" ] \
+ && rm -f "${ROOT}/etc/vdr/tvmovie2vdr/files"
+
+ [ -L "${ROOT}/var/vdr/tvmovie2vdr/tvmovie2vdr" ] \
+ && rm -f "${ROOT}/var/vdr/tvmovie2vdr/tvmovie2vdr"
+
+ eerror "The executable name of tvmovie2vdr changed!"
+ eerror "Old name was tvm2vdr.pl, new is: tvm2vdr"
+ eerror "Please change name in your cron-job!"
+ eerror
+
+ elog "You have to configure the following files:"
+ elog "\t${CONF_DIR}/config.pl"
+ elog "\t${CONF_DIR}/channels_wanted.pl"
+ elog
+ elog "It's a good idea to add the following to /etc/crontab:"
+ elog "\t3 5 * * * vdr /usr/bin/tvinfomerk2vdr"
+ elog "\t7 5 * * * vdr /usr/bin/tvm2vdr"
+ elog
+ elog "To delete old pictures you should run the following command with the tvmovie2vdr run:"
+ elog "\tfind /var/vdr/epgimages/ -type f -mtime +10 -exec rm {} \;"
+ elog "or see tvm2vdr.sh in /usr/share/tvmovie2vdr/contrib"
+ elog
+}