summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilson Michaels <thebitpit@earthlink.net>2020-07-25 13:15:31 -0500
committerAaron Bauman <bman@gentoo.org>2020-08-01 18:23:41 -0400
commit45f60ac4104b48773c19005388b50d60a56415e7 (patch)
tree75bcdc3142d0457bd4f1af2ddf70c2e4542b785d /media-tv/mythtv
parentpackage.mask: last-rite dev-python/pyvorbis (diff)
downloadgentoo-45f60ac4104b48773c19005388b50d60a56415e7.tar.gz
gentoo-45f60ac4104b48773c19005388b50d60a56415e7.tar.bz2
gentoo-45f60ac4104b48773c19005388b50d60a56415e7.zip
media-tv/mythtv: add runtime depend, remove old revision
Closes: https://bugs.gentoo.org/733470 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Wilson Michaels <thebitpit@earthlink.net> Closes: https://github.com/gentoo/gentoo/pull/16817 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/mythtv-31.0-r2.ebuild (renamed from media-tv/mythtv/mythtv-31.0.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-tv/mythtv/mythtv-31.0.ebuild b/media-tv/mythtv/mythtv-31.0-r2.ebuild
index 9d3ead365ea8..8c2640774db3 100644
--- a/media-tv/mythtv/mythtv-31.0.ebuild
+++ b/media-tv/mythtv/mythtv-31.0-r2.ebuild
@@ -137,6 +137,7 @@ DEPEND="
dev-python/future[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mysqlclient[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
')
)
@@ -146,6 +147,7 @@ python_check_deps() {
has_version "dev-python/future[${PYTHON_USEDEP}]" &&
has_version "dev-python/lxml[${PYTHON_USEDEP}]" &&
has_version "dev-python/mysqlclient[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/requests-cache[${PYTHON_USEDEP}]" &&
has_version "dev-python/simplejson[${PYTHON_USEDEP}]"
}
@@ -385,11 +387,11 @@ src_install() {
insinto /usr/share/mythtv/contrib
# Ensure we don't install scripts needing the perl bindings (bug #516968) Finding none is OK.
- if use perl; then
+ if ! use perl; then
find contrib/ -name '*.pl' -exec rm {} \;
fi
# Ensure we don't install scripts needing the python bindings (bug #516968) Finding none is OK.
- if use python; then
+ if ! use python; then
find contrib/ -name '*.py' -exec rm {} \;
fi
doins -r contrib/*