summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-05-10 10:16:16 -0400
committerCraig Andrews <candrews@gentoo.org>2021-05-10 10:17:50 -0400
commitb3152bc7d8ad43f93aa4194ce7939369fda54c27 (patch)
tree057f83a278ed91af844dc459475d1c0a54f2c343 /media-tv/kodi
parentnet-misc/omniORB: add 4.2.4 (diff)
downloadgentoo-b3152bc7d8ad43f93aa4194ce7939369fda54c27.tar.gz
gentoo-b3152bc7d8ad43f93aa4194ce7939369fda54c27.tar.bz2
gentoo-b3152bc7d8ad43f93aa4194ce7939369fda54c27.zip
media-tv/kodi: Pipewire support
See: https://github.com/xbmc/xbmc/commit/97a7602f Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv/kodi')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild4
-rw-r--r--media-tv/kodi/metadata.xml1
2 files changed, 4 insertions, 1 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 1e3017a63585..1d0692f7deee 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -39,7 +39,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical pipewire power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -122,6 +122,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
raspberry-pi? (
|| ( media-libs/raspberrypi-userland media-libs/raspberrypi-userland-bin media-libs/mesa[egl,gles2,video_cards_vc4] )
)
+ pipewire? ( media-video/pipewire )
pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
>=sys-libs/zlib-1.2.11
@@ -285,6 +286,7 @@ src_configure() {
-DENABLE_OPENGL=$(usex !gles)
-DENABLE_OPTICAL=$(usex optical)
-DENABLE_PLIST=$(usex airplay)
+ -DENABLE_PIPEWIRE=$(usex pipewire)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_SMBCLIENT=$(usex samba)
-DENABLE_SNDIO=OFF
diff --git a/media-tv/kodi/metadata.xml b/media-tv/kodi/metadata.xml
index b33526329c7c..215cec6e20fa 100644
--- a/media-tv/kodi/metadata.xml
+++ b/media-tv/kodi/metadata.xml
@@ -20,6 +20,7 @@
<flag name="dav1d">Enables AV1 decoding via <pkg>media-libs/dav1d</pkg></flag>
<flag name="nfs">Enable NFS client support</flag>
<flag name="optical">Enable Audio CD playback, optical disks detection and reading (CD-ROM, Video CD, and others), and ISO optical disk images direct reading. DVD disks may require additional 'udf' flag.</flag>
+ <flag name="pipewire">Enable pipewire support</flag>
<flag name="power-control">Enable control of shutdown, reboot, suspend, and hibernate</flag>
<flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
<flag name="system-ffmpeg">Use system ffmpeg instead of the bundled one</flag>