summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-10-11 12:08:38 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-10-11 12:08:52 +0200
commitcc26fc64fb2667a28475708f9a36016ed6b0718a (patch)
treee1312cf895c2c51981da3617a339e95acdd5201b /media-sound
parentdev-cpp/azure-security-keyvault-certificates: New package at 4.2.1 (diff)
downloadgentoo-cc26fc64fb2667a28475708f9a36016ed6b0718a.tar.gz
gentoo-cc26fc64fb2667a28475708f9a36016ed6b0718a.tar.bz2
gentoo-cc26fc64fb2667a28475708f9a36016ed6b0718a.zip
media-sound/abcmidi: bump to 2024.10.10
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcmidi/Manifest1
-rw-r--r--media-sound/abcmidi/abcmidi-2024.10.10.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index dde7c9738b5b..0403b60a064e 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1 +1,2 @@
DIST abcMIDI-2024.08.13.zip 633931 BLAKE2B eaa3f0c9f070a89b7ba03e369018747c7ad9f684cf8f1ada12797b3a2617e2461a47d0e8ee970d30ed46ae44b300285da54ad41843b6ac4130801ccb032d2c7f SHA512 c808f762e86ddeb9c2a2ec0c36519d78366f8a9b505e94c81365d31d12dfd9b349cbab6ef1004da108741635e4c712e948a721e4352a06bf178a882934bb2a6c
+DIST abcMIDI-2024.10.10.zip 633944 BLAKE2B 4e2b550e945b261c49b1384f7580c83cbfc9f42ad8b2fa4f6ff12285d036bd8e1f66d41554630c8f65ba090d7e4ff852d11365b1003a699558995cf583773ad2 SHA512 a5361865907adedeebf3128259118d180ec0ece5c6e88751a96eaeac32abb2b48f9312ba62e706398d70947368d406763c7254ead967fba6f715f7391b54b42c
diff --git a/media-sound/abcmidi/abcmidi-2024.10.10.ebuild b/media-sound/abcmidi/abcmidi-2024.10.10.ebuild
new file mode 100644
index 000000000000..8aed3dc3a8d2
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2024.10.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ sed -i "s:-O2::" configure.ac || die
+ sed -i "s:@datarootdir@/doc/abcmidi:@docdir@:" Makefile.in || die
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/876421
+ # https://github.com/sshlien/abcmidi/issues/9
+ filter-lto
+
+ default
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}