summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2022-01-24 01:16:10 +0100
committerJonas Stein <jstein@gentoo.org>2022-01-24 01:16:40 +0100
commit99a86280dd5c17853aa5ec778533b9109d65b340 (patch)
treec2bece250e6f940f50b370b8f400fe65c51a11f1 /media-sound
parentdev-libs/ntl: bump the 11.5.1 (soname) subslot. (diff)
downloadgentoo-99a86280dd5c17853aa5ec778533b9109d65b340.tar.gz
gentoo-99a86280dd5c17853aa5ec778533b9109d65b340.tar.bz2
gentoo-99a86280dd5c17853aa5ec778533b9109d65b340.zip
media-sound/grip: bump to 4.2.3
Version bump to 4.2.3 fixed db lookups. Bump to EAPI=8 Clean up inherits Closes: https://bugs.gentoo.org/831941 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/Manifest1
-rw-r--r--media-sound/grip/grip-4.2.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index 032881bc3fcb..58d5382685b3 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1 +1,2 @@
DIST grip-4.2.0.tar.gz 1209972 BLAKE2B 087118b0871b149745fa083f3eeaa79ac8c00c2b094a486cb9c5188e215dd7ce4cb06d13fb362914d7b688c89989e3b6b86ee889b4027e38b727876a06f06dd1 SHA512 26cb32064019da1d1683c44caa3c52ae513cec5b1fb435930e8e4c62433a70f14145d92f2215bf54a5bface96945d3e5e879302e2824029650d2a34218528e94
+DIST grip-4.2.3.tar.gz 1210695 BLAKE2B d4b5cde336fd9db3a68d6ded2375d12c0ac42af86b34067d5eb4b3356bead13e3c5fe967a7932ae9f4be418dbf5136a889fecc0362bf453f4b1d92193013f739 SHA512 05b66c363af31835e534547ae5dcb21340a7b3a824e46b337b511a8ddd0bbd161ab16470b658eb1df3887838b391d71702069da9207160a692e1a8ebae0d52e0
diff --git a/media-sound/grip/grip-4.2.3.ebuild b/media-sound/grip/grip-4.2.3.ebuild
new file mode 100644
index 000000000000..09c22db206c4
--- /dev/null
+++ b/media-sound/grip/grip-4.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs xdg strip-linguas
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}