summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-11-29 10:05:42 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-11-29 10:05:57 +0100
commit96f50bf8816769fb030dd94ade19de5a2b216a95 (patch)
tree67876fd6e66bea2e22608996e33635f5ebc383ed /media-sound
parentdev-python/mkdocs-minify-plugin: Fix testing prior to install (diff)
downloadgentoo-96f50bf8816769fb030dd94ade19de5a2b216a95.tar.gz
gentoo-96f50bf8816769fb030dd94ade19de5a2b216a95.tar.bz2
gentoo-96f50bf8816769fb030dd94ade19de5a2b216a95.zip
media-sound/grip: bump to 4.2.4
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/Manifest1
-rw-r--r--media-sound/grip/grip-4.2.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index c254c90a85fd..6b643ff86859 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1 +1,2 @@
DIST grip-4.2.3.tar.gz 1210695 BLAKE2B d4b5cde336fd9db3a68d6ded2375d12c0ac42af86b34067d5eb4b3356bead13e3c5fe967a7932ae9f4be418dbf5136a889fecc0362bf453f4b1d92193013f739 SHA512 05b66c363af31835e534547ae5dcb21340a7b3a824e46b337b511a8ddd0bbd161ab16470b658eb1df3887838b391d71702069da9207160a692e1a8ebae0d52e0
+DIST grip-4.2.4.tar.gz 1212479 BLAKE2B 58203a4faca90e8662347a5f67b7e026c2235ed53c5dbfe351faf4027608eb9e9c7b106907f2abb0dfffd4d01da33eeb334d2500c7f359314c003dc881e1a863 SHA512 fdc2808b91df617f4d2447114037c31bd5fa0657aa4ea2453e644b155468971c65a364bb0a3c6ed8ff2ba0e44e7117a51bec3081c7defd590f9fbc802a216bf5
diff --git a/media-sound/grip/grip-4.2.4.ebuild b/media-sound/grip/grip-4.2.4.ebuild
new file mode 100644
index 000000000000..09c22db206c4
--- /dev/null
+++ b/media-sound/grip/grip-4.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs xdg strip-linguas
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}