summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-10-25 20:42:37 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-10-26 23:29:21 +0200
commit0375c41e91444b5a8374c0ab6ccb76c5730832bc (patch)
treebb0784e9b7fd877e7461434722a6c409d6952be4 /media-sound
parentsys-kernel/rt-sources: version bump to {3.18.43_p46,4.1.34_p39,4.4.25_p35,4.8... (diff)
downloadgentoo-0375c41e91444b5a8374c0ab6ccb76c5730832bc.tar.gz
gentoo-0375c41e91444b5a8374c0ab6ccb76c5730832bc.tar.bz2
gentoo-0375c41e91444b5a8374c0ab6ccb76c5730832bc.zip
media-sound/flacon: verbump to 2.1.0
Convert many RDEPEND entries to optfeature, since they aren't linked and can be freely removed/installed to adjust flacon features post install. See also: https://github.com/flacon/flacon/issues/35 Gentoo-Bug: https://bugs.gentoo.org/596082 Closes: https://github.com/gentoo/gentoo/pull/2665 Package-Manager: portage-2.3.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/flacon/Manifest1
-rw-r--r--media-sound/flacon/flacon-2.1.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index 626e41a8deb6..04bc114db382 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1 +1,2 @@
DIST flacon-2.0.1.tar.gz 317356 SHA256 3408304e7ab524a2e8a621ea780579e1be7b3359fefe7d37a1b88f34d6120e02 SHA512 d095880f4aba0d528fb03a860aef6cb818af7fea52642db4a42ed26a1e5bf412d6fb8bff604e148a885ac661275fcc43966b3f56fea133e6acb3ccea15fe5f2c WHIRLPOOL e1c95430473616d79396fa42a7d9c8e4e6ac92ccd32e2c74e185e164607f61faeeb59743c052a93fb140a77e3a0b40738716bbe5e2efdae5ae6a99aae693ae9a
+DIST flacon-2.1.0.tar.gz 337008 SHA256 787b84ba6f068bb54954ec4681f21aa815fe6f25f19f43f10942c5fcec967e2d SHA512 30bd08d890274af1a087b8354f243b32daa63ef0cbfff8db44a4826f23adc2cb243aa1e4c4f8140809d3cd9b2414ff7fe60a1fba5f8b5e665e537088dd676217 WHIRLPOOL d26d253dd81e05eeb4d4c01537c79a763806324acad2e2e4ed7371ac7ac9cb9513e2382d1c4518620aecce66c94747b58dcfa77eba4af8d04ec9aad3290f0355
diff --git a/media-sound/flacon/flacon-2.1.0.ebuild b/media-sound/flacon/flacon-2.1.0.ebuild
new file mode 100644
index 000000000000..4ca6d1a15f0b
--- /dev/null
+++ b/media-sound/flacon/flacon-2.1.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Ignore rudimentary et, uz@Latn, zh_TW translation(s).
+PLOCALES="cs cs_CZ de es es_MX fr gl hu it ja_JP lt nb nl pl pl_PL pt_BR pt_PT ro_RO ru sr sr@latin tr uk zh_CN"
+
+inherit cmake-utils eutils gnome2-utils l10n virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5 test"
+
+COMMON_DEPEND="
+ dev-libs/uchardet
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-sound/shntool
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ qt5? ( dev-qt/linguist-tools:5 )
+ test? (
+ media-sound/shntool
+ virtual/ffmpeg
+ !qt5? ( dev-qt/qttest:4 )
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Ignore rudimentary et, uz@Latn, zh_TW translation(s).
+ rm "translations/${PN}_uz@Latn.desktop" || die
+ rm "translations/${PN}"_{et,zh_TW}.ts || die
+
+ remove_locale() {
+ rm "translations/${PN}_${1}".{ts,desktop} || die
+ }
+
+ l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
+ l10n_for_each_disabled_locale_do remove_locale
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT4="$(usex !qt5)"
+ -DUSE_QT5="$(usex qt5)"
+ -DTEST_DATA_DIR="${S}/tests/data/"
+ -DBUILD_TESTS="$(usex test 'Yes')"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "${PN} optionally supports formats listed below."
+ elog "(List will be empty if all extra packages are installed.)"
+ elog "Please install the required packages and restart ${PN}."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}