summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 14:32:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 21:30:51 +0100
commitc68196e3dc5a9688ccb0cd63e68570ea5942687f (patch)
tree9816d80ee2732e5af8e9f6ab38775a53988abb13 /media-sound/vmpk
parentmedia-sound/drumstick: 2.0.0 version bump (diff)
downloadgentoo-c68196e3dc5a9688ccb0cd63e68570ea5942687f.tar.gz
gentoo-c68196e3dc5a9688ccb0cd63e68570ea5942687f.tar.bz2
gentoo-c68196e3dc5a9688ccb0cd63e68570ea5942687f.zip
media-sound/vmpk: 0.8.0 version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/vmpk')
-rw-r--r--media-sound/vmpk/Manifest1
-rw-r--r--media-sound/vmpk/vmpk-0.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/vmpk/Manifest b/media-sound/vmpk/Manifest
index 2804e263990b..985859ac40fa 100644
--- a/media-sound/vmpk/Manifest
+++ b/media-sound/vmpk/Manifest
@@ -1 +1,2 @@
DIST vmpk-0.7.2.tar.bz2 438006 BLAKE2B 78b1f50ce4ec6a430e4b82b500687261c448043d07fcd8e5a8fabcf0554f0488b7a87abf4a208a1d102a86c7b399c0637210c23f7d5b45a5166d6909aeb26b1f SHA512 69e31d6fd91a6604b7482b18840ed0b274723f380d7fe59827391e9031c3c670cb4e331c8bff01aacf6271973689f0bdb8c1dad4b749524095b398063634a477
+DIST vmpk-0.8.0.tar.bz2 466517 BLAKE2B 9fee766b71ad7f9cd96f9dfd859dc31434f14c913c75f5a8e76c66150522dbf04c6e28582269d1603c6d53d6db436e9e7f73cab1172c0d6b004cc71edccb21c8 SHA512 b3e1e40792661c1e4ce3a5274513b4b75742ca861a6233c2653d6df90b7a89e086d15a4196d59c7021c48e9e2aae83116ba29c3395960179d602f0cb06c1f608
diff --git a/media-sound/vmpk/vmpk-0.8.0.ebuild b/media-sound/vmpk/vmpk-0.8.0.ebuild
new file mode 100644
index 000000000000..cd6827e95032
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="https://vmpk.sourceforge.io/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=media-sound/drumstick-2.0.0
+ x11-libs/libxcb
+ dbus? ( dev-qt/qtdbus:5 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=$(usex dbus)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/vmpk/*.html "${D}"/usr/share/doc/${PF}/html/ || die
+}