summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-13 17:58:08 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-13 17:58:25 +0100
commit5d936317e6b3e6056b05666c2843b5499a020477 (patch)
treebeebaf39577e75657908f5108ad11c77cf1687e9 /media-sound/sndfile-tools
parentsys-cluster/ipvsadm: amd64 stable wrt bug #495944 (diff)
downloadgentoo-5d936317e6b3e6056b05666c2843b5499a020477.tar.gz
gentoo-5d936317e6b3e6056b05666c2843b5499a020477.tar.bz2
gentoo-5d936317e6b3e6056b05666c2843b5499a020477.zip
media-sound/sndfile-tools: Prevent configure adding -Werror to CFLAGS
Gentoo-Bug: 542120 * EAPI=6 Package-Manager: portage-2.2.27
Diffstat (limited to 'media-sound/sndfile-tools')
-rw-r--r--media-sound/sndfile-tools/files/sndfile-tools-1.03-remove-Werror.patch16
-rw-r--r--media-sound/sndfile-tools/sndfile-tools-1.03-r1.ebuild24
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/sndfile-tools/files/sndfile-tools-1.03-remove-Werror.patch b/media-sound/sndfile-tools/files/sndfile-tools-1.03-remove-Werror.patch
new file mode 100644
index 000000000000..11c71c79310a
--- /dev/null
+++ b/media-sound/sndfile-tools/files/sndfile-tools-1.03-remove-Werror.patch
@@ -0,0 +1,16 @@
+Remove -Werror from CFLAGS causing all sorts of havoc due to
+deprecated declarations in media-sound/jack-audio-connection-kit
+See also: https://bugs.gentoo.org/show_bug.cgi?id=542120
+
+--- sndfile-tools-1.03/configure
++++ sndfile-tools-1.03/configure
+@@ -11397,9 +11397,6 @@
+ CFLAGS="$CFLAGS -std=gnu99 -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Waggregate-return -Wcast-align -Wcast-qual -Wnested-externs -Wshadow -Wpointer-arith"
+ # -Wundef -Wbad-function-cast -Wmissing-declarations -Wconversion -Winline"
+
+- if test x$ac_arg_gcc_werror = "xyes" ; then
+- CFLAGS="-Werror $CFLAGS"
+- fi
+
+
+ $as_echo "#define COMPILER_IS_GCC 1" >>confdefs.h
diff --git a/media-sound/sndfile-tools/sndfile-tools-1.03-r1.ebuild b/media-sound/sndfile-tools/sndfile-tools-1.03-r1.ebuild
new file mode 100644
index 000000000000..1b409a5e1264
--- /dev/null
+++ b/media-sound/sndfile-tools/sndfile-tools-1.03-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A small collection of programs that use libsndfile"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
+SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=media-libs/libsndfile-1.0.19
+ >=x11-libs/cairo-1.4.0
+ sci-libs/fftw:3.0
+ media-sound/jack-audio-connection-kit"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-remove-Werror.patch"
+)